Opened 7 years ago

Closed 4 years ago

#8427 closed bug (fixed)

[UserlandFS] crashes after second mount attempt

Reported by: diver Owned by: bonefish
Priority: normal Milestone: R1
Component: File Systems/UserlandFS Version: R1/Development
Keywords: Cc: Diger
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev43901 gcc2hybrid.
Start userlandfs_server:

echo password | /system/servers/userlandfs_server sshfs

Mount remote folder:

mount -t userlandfs -o 'sshfs user@server:./ -o password_stdin' user

If you mount it again Haiku will panic.

Attachments (2)

sshfs_panic.png (48.6 KB) - added by diver 7 years ago.
sshfs.zip (153.3 KB) - added by diver 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by diver

Attachment: sshfs_panic.png added

Changed 7 years ago by diver

Attachment: sshfs.zip added

comment:1 Changed 4 years ago by diver

Could this be fixed with hrev48955?

comment:2 in reply to:  1 Changed 4 years ago by mmlr

Replying to diver:

Could this be fixed with hrev48955?

Only if there were more than one SSHFS volumes mounted at the same time at one point and then one of them was unmounted. A crash just by mounting multiple volumes would indicate a different problem. Can you still reproduce the crash?

comment:3 Changed 4 years ago by diver

Resolution: fixed
Status: newclosed

I've just tested and it doesn't crash anymore. However, I can't test on previous revision (hrev48953) because I can't activate/deactivate any packages when booted in previous state from the bootloader.

Note: See TracTickets for help on using tickets.