Opened 7 years ago

Closed 4 years ago

#8441 closed bug (fixed)

MediaPlayer crashes on quit

Reported by: Disreali Owned by: korli
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Experienced on hrev43877-2hn.

Steps to reproduce:

  1. Start MediaPlayer.
  1. Quit MediaPlayer.
  1. MediaPlayer crashes.

Attaching syslog and backtrace.

Attachments (3)

syslog_hrev43877-2hn_mediaplayer_crash_on_quit.txt (2.4 KB) - added by Disreali 7 years ago.
hrev-43877-2hn_mediaplayer_crash_on_quit.txt (4.2 KB) - added by Disreali 7 years ago.
hrev43932_mediaplayer_crash_on_quit.txt (3.2 KB) - added by Disreali 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Disreali

comment:1 Changed 7 years ago by anevilyak

Component: Applications/MediaPlayerAudio & Video/Codecs
Owner: changed from stippi to korli
Status: newassigned

Looks like it's actually the ffmpeg addon that's crashing.

comment:2 Changed 7 years ago by Disreali

It seems to be fixed in hrev43932. Sorry for the noise.

comment:3 Changed 7 years ago by diver

Resolution: fixed
Status: assignedclosed

comment:4 Changed 7 years ago by Disreali

Resolution: fixed
Status: closedreopened

I spoke to soon. Though, I get a different backtrace this time.

Changed 7 years ago by Disreali

comment:5 Changed 6 years ago by Freeman

System: Haiku R1Alpha4-44702 on Virtualbox v4.2.4r81684 Windows Ultimate x64. CPU: i5 3570k 3.4 ghz ( 1 Cpu allocated to Haiku) Ram: 4gb ddr3 (2gb allocated to Haiku) Video memory: 8mb allocated to Haiku . Acceleration not enabled in Virtualbox

Bug not present anymore.

comment:6 Changed 4 years ago by diver

Resolution: fixed
Status: reopenedclosed

The last back trace is different from the first one. Assuming fixed. If you can still reproduce it please reopen and attach debug report.

Note: See TracTickets for help on using tickets.