Opened 8 years ago

Closed 8 years ago

#8458 closed bug (fixed)

Problem playing mp3 files

Reported by: grimus Owned by: korli
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/Development
Keywords: ffmpeg, mp3 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

mp3 files with embedded album art will not play. (General System Error)

These files play on several other players with no problem. And files without embedded album art play fine.

Nightly hrev43955

Change History (8)

comment:1 by diver, 8 years ago

Component: Audio & VideoAudio & Video/Codecs
Description: modified (diff)
Keywords: ffmpeg mp3 added
Owner: changed from nobody to korli
Platform: x86-64All
Status: newassigned

comment:2 by diver, 8 years ago

I get the same error with several video clips a have. Running MediaPlayer from Terminal doesn't show any useful info.

comment:3 by korli, 8 years ago

Any sample files?

comment:5 by diver, 8 years ago

mplayer info:

MPEG-PS file format detected.
VIDEO:  MPEG1  352x288  (aspect 8)  25.000 fps  1150.0 kbps (143.8 kbyte/s
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmpeg1] vfm: ffmpeg (FFmpeg MPEG-1)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 224.0 kbit/15.87% (ratio: 28000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 352x288 => 384x288 Planar YV12

comment:6 by korli, 8 years ago

Please check with hrev43989. It fixed it for the provided file.

comment:7 by grimus, 8 years ago

Tested with hrev43990 and now mp3 files with embedded album art play fine.

Great responce many thanks. Ticket can be closed for my problem.

comment:8 by korli, 8 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.