Opened 7 years ago

Closed 7 years ago

#8483 closed bug (fixed)

WebPositive crashes trying to view certain images.jpg on the internet

Reported by: HAL Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/alpha3
Keywords: WebPositive segment violation website picture image Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have only observed this trying to view images in Haiku bug tracker so far but might also be seen at other websites.

  1. open WebPositive at:

https://dev.haiku-os.org/attachment/ticket/8459

  1. Click on boot3.jpg or boot2.jpg

Result: WebPositive crashes. Reproducible every time. In 2 instead of clicking on those links click on IMG_0003.JPG IMG_0004.JPG IMG_0005.JPG IMG_0006.JPG IMG_0007.JPG or IMG_0008.JPG there is no crash. I am able to open the first two images in Bezilla without it crashing so the images are not corrupt.

Attachments (2)

WebPositive Crashed when Openning Image in Haiku Trac (4.8 KB ) - added by HAL 7 years ago.
gdb and bactrace WebPostive segment violation
Another WebPositive Crash Openning Image at Jpl.nasa (4.9 KB ) - added by HAL 7 years ago.
Identical backtrace at another website

Download all attachments as: .zip

Change History (6)

by HAL, 7 years ago

gdb and bactrace WebPostive segment violation

comment:1 by HAL, 7 years ago

I was testing WebPositive svn revision 586 in Haiku hrev44058 gcc4 hybrid.

comment:2 by HAL, 7 years ago

I just found another website where WebPositive, loading an enlarged version of an image, crashes. The link to where this happens is: http://www.jpl.nasa.gov/images/msl/20120207/curious20120207-full.jpg It makes an identical back trace to the first.

by HAL, 7 years ago

Identical backtrace at another website

comment:3 by mmadia, 7 years ago

Hi. Our WebKit port (and thus WebPositive) was updated in July. Could you retest this in a new nightly image and report back? http://www.haiku-files.org/haiku/development Thanks!

comment:4 by leavengood, 7 years ago

Resolution: fixed
Status: newclosed

I tested and this does not happen anymore on the latest WebKit. Though I will say the loading of the NASA image did not produce the best progress feedback. It almost seemed like it wasn't loading. But we don't yet have a tab loading animation which is part of it. But since this exact crash no longer happens, I'm closing this bug.

Note: See TracTickets for help on using tickets.