Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#85 closed bug (fixed)

Popup menu problems (Backgrounds pref app)

Reported by: korli Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • An already marked menu item can't be selected.
  • Default label for a menu field isn't set based on the pop up menu as on R5.

The menu field inited label is kept, although menu items have been added to the popup menu.

Attachments (1)

label.png (14.7 KB) - added by jackburton 13 years ago.
screenshot of Backgrounds

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by korli

Owner: changed from bpmagic@… to jackburton

comment:2 Changed 13 years ago by jackburton

Status: newassigned

comment:3 Changed 13 years ago by jackburton

"* An already marked menu item can't be selected." Acknowledged. A fix is coming.

"* Default label for a menu field isn't set based on the pop up menu as on R5. The menu field inited label is kept, although menu items have been added to the popup menu."

I can't reproduce this. When I select a different item, the menu field label changes accordingly. Can you elaborate more on this?

comment:4 Changed 13 years ago by jackburton

"* An already marked menu item can't be selected."

Fixed.

comment:5 Changed 13 years ago by korli

""* Default label for a menu field isn't set based on the pop up menu as on R5. The menu field inited label is kept, although menu items have been added to the popup menu."

I can't reproduce this. When I select a different item, the menu field label changes accordingly. Can you elaborate more on this?"

=> Open Backgrounds on Haiku => note the default label on Image menu field : it displays "pick one" though it should be "None" as on R5.

comment:6 Changed 13 years ago by jackburton

As you can see, There's "NONE", as it should be.

comment:7 Changed 13 years ago by korli

OK I didn't reproduce it on VMware, so I'll see if my partition is corrupt or something.

Changed 13 years ago by jackburton

Attachment: label.png added

screenshot of Backgrounds

comment:8 Changed 13 years ago by jackburton

Should I consider this bug closed ?

comment:9 Changed 13 years ago by korli

That's ok for me, Backgrounds must be unstable with weird data on disk.

comment:10 Changed 13 years ago by korli

Status: assignedclosed

comment:11 Changed 13 years ago by korli

Resolution: fixed
Note: See TracTickets for help on using tickets.