Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#85 closed bug (fixed)

Popup menu problems (Backgrounds pref app)

Reported by: korli Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • An already marked menu item can't be selected.
  • Default label for a menu field isn't set based on the pop up menu as on R5.

The menu field inited label is kept, although menu items have been added to the popup menu.

Attachments (1)

label.png (14.7 KB ) - added by jackburton 14 years ago.
screenshot of Backgrounds

Download all attachments as: .zip

Change History (12)

comment:1 by korli, 14 years ago

Owner: changed from bpmagic@… to jackburton

comment:2 by jackburton, 14 years ago

Status: newassigned

comment:3 by jackburton, 14 years ago

"* An already marked menu item can't be selected." Acknowledged. A fix is coming.

"* Default label for a menu field isn't set based on the pop up menu as on R5. The menu field inited label is kept, although menu items have been added to the popup menu."

I can't reproduce this. When I select a different item, the menu field label changes accordingly. Can you elaborate more on this?

comment:4 by jackburton, 14 years ago

"* An already marked menu item can't be selected."

Fixed.

comment:5 by korli, 14 years ago

""* Default label for a menu field isn't set based on the pop up menu as on R5. The menu field inited label is kept, although menu items have been added to the popup menu."

I can't reproduce this. When I select a different item, the menu field label changes accordingly. Can you elaborate more on this?"

=> Open Backgrounds on Haiku => note the default label on Image menu field : it displays "pick one" though it should be "None" as on R5.

comment:6 by jackburton, 14 years ago

As you can see, There's "NONE", as it should be.

comment:7 by korli, 14 years ago

OK I didn't reproduce it on VMware, so I'll see if my partition is corrupt or something.

by jackburton, 14 years ago

Attachment: label.png added

screenshot of Backgrounds

comment:8 by jackburton, 14 years ago

Should I consider this bug closed ?

comment:9 by korli, 14 years ago

That's ok for me, Backgrounds must be unstable with weird data on disk.

comment:10 by korli, 14 years ago

Status: assignedclosed

comment:11 by korli, 14 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.