Opened 8 years ago

Closed 4 months ago

Last modified 3 months ago

#8529 closed bug (fixed)

[deskbar] deadlock while holding ctrl & alt & middle clicking the leaf menu

Reported by: augiedoggie Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #9088
Platform: All

Description

I noticed that middle clicking the leaf menu while holding the control and alt keys will often cause Deskbar to become deadlocked with the menu open. Pressing escape can make the menu go away, but Deskbar remains in an unusable state. This is on hrev44113

Change History (6)

comment:1 by anevilyak, 8 years ago

Probably related to #8523. BMenuBar's tracking loop is trying to lock the window, while the window is in MouseMoved trying to destroy ExpandoMenuBar, which waits for the menu thread to exit -> deadlock.

comment:2 by diver, 8 years ago

It seems that it doesn't deadlock anymore but it often lock-ups for several seconds while dragging.

comment:3 by diver, 8 years ago

Blocking: 9088 added

comment:4 by anevilyak, 5 years ago

Owner: changed from anevilyak to nobody
Status: newassigned

comment:5 by diver, 4 months ago

Resolution: fixed
Status: assignedclosed

Can't reproduce. Closing as fixed.

comment:6 by nielx, 3 months ago

Milestone: R1R1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.