Opened 13 years ago

Closed 12 years ago

Last modified 9 years ago

#856 closed bug (duplicate)

Build failds on arch x86_64

Reported by: johndrinkwater Owned by: admin
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

How to reproduce:
Run on a x86_64 hosted machine, fyi, Fedora Core 4 on an AMD 64.

./configure --build-cross-tools-gcc4 x86 ../buildtools/
jam -q haiku-image

Building fails with:

Link generated/objects/linux/lib/libroot_build.so
/usr/bin/ld: generated/objects/linux/release/build/libroot/errors.o: relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
generated/objects/linux/release/build/libroot/errors.o: could not read symbols: Bad value
collect2: ld returned 1 exit status

cc -shared -Xlinker -soname="libroot_build.so" -o "generated/objects/linux/lib/libroot_build.so"   "generated/objects/linux/release/build/libroot/byteorder.o" "generated/objects/linux/release/build/libroot/errors.o" "generated/objects/linux/release/build/libroot/fs.o" "generated/objects/linux/release/build/libroot/fs_attr.o" "generated/objects/linux/release/build/libroot/misc.o" "generated/objects/linux/release/build/libroot/sem.o" "generated/objects/linux/release/build/libroot/thread.o" "generated/objects/linux/release/build/libroot/strlcpy.o" "generated/objects/linux/release/build/libroot/strlcat.o" "generated/objects/linux/release/build/libroot/strnlen.o"  -lstdc++  ;

Tried adding -fPIC into build/jam/BuildSetup, but doesn't work. Though probably have been editing the wrong var.

Change History (5)

comment:1 Changed 13 years ago by wkornewald

Milestone: R1
Version: R1 development

comment:2 Changed 13 years ago by netster403

hmm i see this error on my linux from scratch machine running clean 64-bit binaries. I may be able to fix this if my Mainboard RMA ever gets returned :((

comment:3 Changed 12 years ago by stim

Platform: Allx64

This seems to be a dupe of #845 to me.

comment:4 Changed 12 years ago by axeld

Resolution: duplicate
Status: newclosed

comment:5 Changed 9 years ago by mmadia

Platform: x64x86-64
Note: See TracTickets for help on using tickets.