Opened 7 years ago

Closed 6 years ago

#8566 closed bug (fixed)

[notification_server] use close button from Web+

Reported by: diver Owned by: leavengood
Priority: normal Milestone: R1
Component: Servers/notification_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Attachments (3)

notification.png (30.0 KB) - added by diver 7 years ago.
notification_mockup.png (14.7 KB) - added by diver 7 years ago.
notification_changes.png (38.5 KB) - added by leavengood 6 years ago.
A real screenshot of experimental changes

Download all attachments as: .zip

Change History (12)

comment:1 Changed 7 years ago by X512

I think that remove cross button in all cases is a better solution :) Cross for Windows and rectangle for Haiku. See BeZilla.

Last edited 7 years ago by X512 (previous) (diff)

comment:2 Changed 7 years ago by pulkomandy

Done in hrev44765.

Using a rectangle does not make it clear that it is a "close" button, so I'd rather avoid it ?

Last edited 7 years ago by diver (previous) (diff)

comment:3 Changed 7 years ago by pulkomandy

Resolution: fixed
Status: newclosed

comment:4 Changed 7 years ago by diver

Resolution: fixed
Status: closedreopened

There is a regression, though: Label in AppGroupView appears 2 pixels higher than before:

While I'm at it I'd like to propose some improvements:

  1. Move label 2 pixels lower as it was before
  2. Add pressed state to close widget.
  3. Don't show 2 close buttons in case of a single notification.
  4. Change AppGroupView height to match Deskbar leaf button height

Changed 7 years ago by diver

Attachment: notification.png added

Changed 7 years ago by diver

Attachment: notification_mockup.png added

comment:5 Changed 6 years ago by leavengood

+1 to diver's last mockup.

comment:6 Changed 6 years ago by axeld

You know, flat is modern nowadays ;-)

Changed 6 years ago by leavengood

Attachment: notification_changes.png added

A real screenshot of experimental changes

comment:7 Changed 6 years ago by leavengood

I have started working on implementing diver's mock-up, and here is what it looks like:

A real screenshot of experimental changes

What do you think diver?

comment:8 Changed 6 years ago by leavengood

Owner: changed from pulkomandy to leavengood
Status: reopenedin-progress

Take ownership.

comment:9 Changed 6 years ago by leavengood

Resolution: fixed
Status: in-progressclosed

OK, this has been committed in hrev45349.

Note: See TracTickets for help on using tickets.