Opened 8 years ago

Closed 8 years ago

#8589 closed bug (duplicate)

Regression: Computer doesn't poweroff

Reported by: drcouzelis Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: regression poweroff ohci interrupts Cc:
Blocked By: #8588 Blocking:
Platform: x86

Description

When performing the "Shutdown" command, my computer does not shutdown completely. Instead, it "hangs" just before powering off the computer, with the message "Shutting down...".

I tested nightly builds until I found when it stopped working:

hrev41505 (2011-05-14) Computer will shutdown and poweroff correctly.

hrev41539 (2011-05-18) Computer will shutdown but fail to poweroff.

I have a GIGABYTE GA-MA770-DS3 motherboard: http://www.newegg.com/Product/Product.aspx?Item=N82E16813128081

Please let me know if I can provide more information. Thank you.

Change History (6)

comment:1 by drcouzelis, 8 years ago

The regression occurred here:

hrev41512 - Shutdown works correctly

hrev41513 - Computer doesn't shutdown correctly

Please see ticket #8588. Thank you.

comment:2 by anevilyak, 8 years ago

Component: SystemDrivers/USB
Keywords: ohci interrupts added
Owner: changed from nobody to mmlr

comment:3 by luroh, 8 years ago

drcouzelis: perhaps it would be worth trying hrev44340 or newer.

comment:4 by drcouzelis, 8 years ago

Thank you for the suggestion. I tried hrev44348. I'm afraid this bug is not resolved.

...Actually, I found out now my ethernet card no longer works. :( I'll do more tests to find the problem.

comment:5 by drcouzelis, 8 years ago

Ok, I finished testing. My ethernet card apparently works fine with the latest builds. Maybe it was a stale config file problem. I don't know. :P

Anyway, I'm sorry I wasn't very clear above: This bug was introduced at the same time as ticket #8588. The "patch" I provided that fixes #8588 also fixes this bug.

I say "patch" in quotes because, as is recorded on the other ticket, it fixes my problems but introduces problems for other people. Which is too bad, because I thought I had a nice normal open source software friendly Gigabyte motherboard. It makes me wonder how many computers need my patch to work and how many don't need it to work. :/

comment:6 by tqh, 8 years ago

Blocked By: 8588 added
Resolution: duplicate
Status: newclosed

Same problem as #8588.

Note: See TracTickets for help on using tickets.