Opened 7 years ago

Closed 13 months ago

#8605 closed bug (fixed)

[MediaPlayer] When fast forwarding or pausing and resuming a video, audio of an .mkv video stops playing.

Reported by: elvis4526 Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I play for instance, an .mkv video with media player, and I fast forward or pause and resume the video, audio crash and I have to repause and re-resume the video a couple of time if I want that the sound comes back. My specs:

  • Latest Haiku Nightly Build
  • Radeon HD 5770
  • AMD phenom x6 1055T

PS: I'm very familliar with UNIX-like OS, but with Haiku, I'm unexperienced so if you need anything else, just ask me.

Change History (5)

comment:1 Changed 7 years ago by anevilyak

Component: Audio & VideoApplications/MediaPlayer
Owner: changed from nobody to stippi
Summary: [MediaPlayer] When fast forwarding or pausing and resuming a video, audio of an .mkv video crash.[MediaPlayer] When fast forwarding or pausing and resuming a video, audio of an .mkv video stops playing.

comment:2 Changed 7 years ago by diver

Could you run MediaPlayer from Terminal and repeat your steps to reproduce this problem and attach terminal output?

comment:3 Changed 7 years ago by Freeman

System: Haiku R1Alpha4-44702 on Virtualbox v4.2.4r81684 Windows Ultimate x64. CPU: i5 3570k 3.4 ghz ( 1 Cpu allocated to Haiku) Ram: 4gb ddr3 (2gb allocated to Haiku) Video memory: 8mb allocated to Haiku . Acceleration not enabled in Virtualbox

I do not get any errors with audio pausing/resuming, or fast forwarding. Could be due to hardware differences thought. Are you still getting this error elvis4526?

comment:4 Changed 13 months ago by waddlesplash

Couldn't reproduce on the https://github.com/haikuports/haikuports/pull/2758 branch; so either fixed by that or indeed fixed earlier.

comment:5 Changed 13 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Fixed in hrev52057.

Note: See TracTickets for help on using tickets.