Opened 7 years ago

Closed 13 months ago

#8641 closed bug (fixed)

[Deskbar] TimeView overlaps other replicants

Reported by: diver Owned by: jscipione
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc: Diger
Blocked By: Blocking: #9103, #9745, #9828
Has a Patch: no Platform: All

Description

This is hrev44242.

  • Open Deskbar preferences
  • Check Auto-hide
  • Check Show seconds
  • Move cursor to the upper right corner to show Deskbar

Attachments (4)

Deskbar.png (5.8 KB) - added by diver 7 years ago.
Deskbar_hrev51536.png (31.3 KB) - added by diver 21 months ago.
Deskbar_hrev51555.png (30.6 KB) - added by diver 20 months ago.
deskbar.png (8.4 KB) - added by diver 20 months ago.

Download all attachments as: .zip

Change History (21)

Changed 7 years ago by diver

Attachment: Deskbar.png added

comment:1 Changed 7 years ago by diver

Blocking: 9103 added

comment:2 Changed 6 years ago by diver

Still here in hrev45313.

comment:3 Changed 6 years ago by anevilyak

Blocking: 9745 added

comment:4 Changed 6 years ago by diver

Blocking: 9828 added

comment:5 Changed 3 years ago by diver

Owner: changed from axeld to jscipione
Status: newassigned

Can't reproduce anymore. Was it fixed in the meantime?

comment:6 Changed 2 years ago by jscipione

This issue is still not fixed, but, may be harder to reproduce. I've done some work in my various Deskbar branches to mitigate this bug, but I've seen it pop up occasionally still. One easy way to reproduce it is to load the battery replicant and turn on "Show text label" and the battery percentage will overrun the clock.

comment:7 Changed 21 months ago by jscipione

Clock replicant behavior improved in hrev51524, diver please check and see if this one can be closed.

Changed 21 months ago by diver

Attachment: Deskbar_hrev51536.png added

comment:8 Changed 21 months ago by diver

Has a Patch: set

comment:9 Changed 21 months ago by diver

Still here:

comment:10 Changed 20 months ago by jscipione

The above issues has been addressed in hrev51554 which was caused by a bad assumption on my part that the first icon would always fit on the first line... if you have a width enough clock it doesn't.

comment:11 Changed 20 months ago by jscipione

There is still an issue where when the clock changes from 3 digit time (9:59) to 4 digit time (10:00) it doesn't realign the replicants

Changed 20 months ago by diver

Attachment: Deskbar_hrev51555.png added

comment:12 Changed 20 months ago by diver

TimeView is now cut off from both sides, moreover, toggling Show day of week moves TimeView a fix pixels up or down and changes font size a bit.

comment:13 Changed 20 months ago by diver

Correction: only right side is cut off, the left side overlaps dragger.

comment:14 Changed 20 months ago by jscipione

I see the problem. This is caused by time view's maximum width being too wide. A quick fix would be to lower the maximum clock width so that it fits again. Unfortunately this is maximum is currently set 1 time in the constructor so if you expand the window you won't get any additional room for a wide clock. A better approach would be to calculate the max clock based on current window width instead.

Changed 20 months ago by diver

Attachment: deskbar.png added

comment:15 Changed 20 months ago by diver

Looks like the same problem as in the screenshot in the description. This is with Deskbar along the bottom.

comment:16 Changed 18 months ago by pulkomandy

Has a Patch: unset

comment:17 Changed 13 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev52063.

Note: See TracTickets for help on using tickets.