Opened 7 years ago

Closed 5 years ago

#8739 closed bug (fixed)

Webpositive can't open some html files unless file extension added.

Reported by: jstressman Owned by: aldeck
Priority: normal Milestone: R1
Component: Kits/Storage Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm not sure what's happening, but Web+ won't open the Deutsch Wonderbrush Tutorial (included in the installation directory) unless a file extension is added.

(.txt causes it to open as text, .html and .htm open as a web page, .php exhibits the same behavior as no extension, etc...)

Not sure if this is a fault with Web+, or an underlying issue. Qupzilla does basically the same thing, which makes me wonder if it's a webkit issue.

On a side note, if I copy the "cmake-commands.html" documentation file to the desktop and remove the file extension, Web+ can still open it, but Qupzilla can't. I even stripped out the doctype etc all the way to just a plain <html> start for the file and it still loaded in Web+ with no extension.

hrev44335 (gcc2h)

Attachments (2)

webpositiveext1.png (34.0 KB ) - added by jstressman 7 years ago.
file type is text/html but the page still won't load unless you specify the extension.
webpositiveext2.png (54.3 KB ) - added by jstressman 7 years ago.
once you add the extension the file loads just fine.

Download all attachments as: .zip

Change History (6)

comment:1 by aldeck, 7 years ago

Owner: changed from leavengood to aldeck
Status: newassigned

That's a regression of the port upgrade, i've already fixed a similar problem, will look into it asap.

comment:2 by aldeck, 7 years ago

Component: Applications/WebPositiveKits/Storage Kit

I tried with the Deutsch Wonderbrush Tutorial and it works here. I rechecked the haiku-webkit code and we use Haiku's StorageKit (BNodeInfo::GetType) to get the type info. The regression i suspected in my last comment had already been fixed several weeks ago.

So everything looks fine on the webkit side, Haiku got the mime type wrong for another reason in your case. Leaving the ticket open until we find out why, but changing component. I wouldn't be surprised if there was an existing duplicate ticket though.

comment:3 by leavengood, 7 years ago

jstressman:

Can you try to reproduce this again and see what file type this file is? You can see that by opening it with the FileTypes Tracker add-on.

WebPositive will respect the Haiku file type more than the extension. For example I ran across an issue myself where a file I had created in StyledEdit with an html extension would not render as HTML in WebPositive because it had a file type of text/plain. Once I made it text/html it rendered.

by jstressman, 7 years ago

Attachment: webpositiveext1.png added

file type is text/html but the page still won't load unless you specify the extension.

by jstressman, 7 years ago

Attachment: webpositiveext2.png added

once you add the extension the file loads just fine.

comment:4 by pulkomandy, 5 years ago

Resolution: fixed
Status: assignedclosed

Works fine now.

Note: See TracTickets for help on using tickets.