Opened 13 years ago

Closed 13 years ago

#874 closed bug (duplicate)

[kernel] DiskScaner can't find haiku partition

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Storage Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I can't boot haiku anymore due to disk scaner can't find my haiku partition. Earler i could boot haiku on the same hardware just fine until i relayout my partitions. My current partition map: 20Gb - ntfs (primary) 20Gb - hpfs+(primary) 20Gb - bfs - R5 (logical) 10GB - bfs - Dano/zeta (logical) 5GB - bfs - Haiku (logical) 2gb - Linux swap (logical) 20Gb - ext3 (logical) 200Gb - ntfs (logical)

And yes, i initialized haiku partition, build the most recent revision (18970) and installed haiku on this partition.

Strange thing is that i can boot haiku from this partition via vmware if i choose physical disk there (though, Trash have folder icon).

From another user i heard that he have the same problem (can't boot haiku) with several his pc his work with hdd wich have several partitions.

I use bootman as my boot manager, when i select Haiku from os list it vrings me to menu where is says <No boot volume found> (haiku/src/system/boot/loader/menu.cpp)

I saved my mbr with this command dd if=/dev/disk/scsi/0/0/0/raw of=mbr.save so someone could analyse whats worng.

This is my motherboard: http://www.msi.com.tw/program/support/download/dld/spt_dld_detail.php?UID=91&kind=1 My bios is Award v2.3 http://www.msi.com.tw/program/support/bios/bos/spt_bos_detail.php?UID=91&kind=1 My hard drive Seagate Barracuda 300gb pata

I can't continue to test Haiku on real hw until this bug fixed :-( Hope this will help...

Attachments (1)

mbr.save (1.0 KB) - added by diver 13 years ago.
my mbr

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by diver

Attachment: mbr.save added

my mbr

comment:1 Changed 13 years ago by diver

corrections: /s/hpfs+/hfs+ /s/several his pc his work/several his pc on his work /s/vrings/brings /s/is says/it says sorry

comment:2 Changed 13 years ago by diver

Hmm, trac indeed munches lines bug #846...

comment:3 Changed 13 years ago by axeld

Resolution: duplicate
Status: newclosed

This is a duplicate of bug #238.

Note: See TracTickets for help on using tickets.