Opened 7 years ago

Closed 7 years ago

#8760 closed bug (invalid)

Missing people folder in home folder in nightly builds

Reported by: Robert S. Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: File Systems/BFS Version: R1/Development
Keywords: BFS index Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In the current nightly builds there is the people folder missing. But this is not the real problem. The problem is that, if you create a people folder in the home folder you need to reboot after this, otherwise all files in the home folder are out of index.

To rebuild: create people folder in a new nightly installation, create a NEW people file in the people folder, try to find it with a query

Change History (7)

comment:1 Changed 7 years ago by anevilyak

Works correctly here, I'm not sure I understand the problem. Are you booting the nightly off a CD, a USB stick, or what?

comment:2 Changed 7 years ago by Robert S.

No, i installed a new nightlybuild to my harddrive from a usb stick. Than I boot the new installed nightlybuild... and than i create the people folder, than i create a people file in the people folder and than the new people file is not in the index and can not be found with a BQuery.

Last edited 7 years ago by Robert S. (previous) (diff)

comment:3 Changed 7 years ago by Robert S.

That is the BQuery i use:

BVolumeRoster *volumes = new BVolumeRoster();

BVolume *volume = new BVolume(); while(volumes->GetNextVolume(volume) == B_NO_ERROR) {

BQuery *mContactQuery = new BQuery();

mContactQuery->SetVolume(volume);

mContactQuery->SetTarget(*messengerQueryLooper); BString predicate("((META:name==*)&&(BEOS:TYPE==\"application/x-person\"))"); mContactQuery->SetPredicate(predicate.String());

status_t res = mContactQuery->Fetch(); if(res == B_OK) {

entry_ref ref; while (mContactQuery->GetNextRef(&ref) == B_OK) {

/*some code ;)*/

}

}

}

Last edited 7 years ago by Robert S. (previous) (diff)

comment:4 Changed 7 years ago by anevilyak

Out of curiosity, does the same problem arise if you use Tracker to query for it? I can't reproduce this at all. Also, if you run lsindex, what's the output?

comment:5 Changed 7 years ago by anevilyak

The sample code works as expected over here. Have you tried running checkfs on that volume?

comment:6 Changed 7 years ago by Robert S.

Hi,

i didn't tried it with the tracker. I will do it tomorrow. I tested it with some installations on diffrent computers and diffrent nightlybuilds (in virtual machines and real hardware) i could reproduce it on every system. I will try it tomorrow on a new installation again and will post the output of lsindex.

EDIT: maybe interessting as well, after creating the people folder it has a standard folder icon and not the "people folder icon" it gets the "people folder icon" just after a reboot.

Last edited 7 years ago by Robert S. (previous) (diff)

comment:7 Changed 7 years ago by anevilyak

Resolution: invalid
Status: newclosed

After further diagnosis over IRC, problem appears to be in user app's code. Closing as invalid.

Note: See TracTickets for help on using tickets.