Opened 7 years ago

Closed 6 years ago

#8784 closed bug (fixed)

WebPositive rendering bug window wider than desktop

Reported by: jessicah Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I resize WebPositive's window to be larger than the desktop (so I can view more of the webpage content), the area to the right that would lie off screen if the left edge of the window were visible does not get painted.

Also, layout of the page is restricted to the part of the window that actually gets painted, rather than the width of the window.

Attachments (1)

web+_region-not-rendered-to.png (144.3 KB ) - added by jessicah 7 years ago.

Download all attachments as: .zip

Change History (4)

by jessicah, 7 years ago

comment:1 by Disreali, 7 years ago

I think the issue in the screen capture may be how the Haiku-os sit is formatted. Does the same issue happen with other sites?

comment:2 by leavengood, 7 years ago

I cannot reproduce this on hrev44431 with the latest WebPositive and WebKit. I do sometimes see "scrollbar tearing" on resizing, but I think that is another issue. When the page is scrolled vertically any scrollbar tearing after a resize is painted over, so it definitely seems this issue does not happen now.

I loaded the same page in the screenshot and made the window really wide and moved off the screen.

jessicah: Could you retest on a newer Haiku?

comment:3 by pulkomandy, 6 years ago

Resolution: fixed
Status: newclosed

Assuming this is fixed. If you can reproduce, please include more detailed steps.

Note: See TracTickets for help on using tickets.