Opened 7 years ago

Closed 7 years ago

#8841 closed bug (fixed)

3rd party applications localization support was broken in hrev44041.

Reported by: siarzhuk Owned by: zooey
Priority: normal Milestone: R1/alpha4
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm trying to fix localization support in makefile and Jamfile engines to let them work in actual Haiku revisions. The problem is that the way of strings collecting was changed in hrev44041. Currently it is required to include special version of Catalog.h during collecting phase. This special Catalog.h lives in private headers area and is not available for 3rd party applications.

More detailed discussion is in [haiku-development] http://www.freelists.org/post/haiku-development/3rd-party-applications-localization-support-in-posthrev44041-times

Change History (1)

comment:1 Changed 7 years ago by zooey

Resolution: fixed
Status: newclosed

Fixed in hrev44546:

The define B_COLLECTING_CATKEYS is now back, if it is set, the catalog-related macros will not automatically be switched to the versions suitable for collecting the catalog keys.

Note: See TracTickets for help on using tickets.