Opened 13 years ago

Closed 12 years ago

#886 closed bug (fixed)

[BeMail] crash on font change

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: korli@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

BeMail crashes on font change in preferences. back trace will follow.

Attachments (3)

BeMail.txt (2.7 KB) - added by diver 13 years ago.
bt
bemail.PNG (42.9 KB) - added by jackburton 12 years ago.
a different stack trace
textview.patch (864 bytes) - added by jackburton 12 years ago.
Bug Fix

Download all attachments as: .zip

Change History (11)

Changed 13 years ago by diver

Attachment: BeMail.txt added

bt

comment:1 Changed 12 years ago by axeld

Component: GeneralApplications/BeMail

comment:2 Changed 12 years ago by axeld

Owner: changed from axeld to jackburton

This looks like a BTextView problem.

comment:3 Changed 12 years ago by jackburton

Status: newassigned

comment:4 Changed 12 years ago by jackburton

Component: Applications/BeMailUser Interface/Interface Kit

Changed 12 years ago by jackburton

Attachment: bemail.PNG added

a different stack trace

comment:5 Changed 12 years ago by jackburton

This might be also a locking issue, as it isn't reproducible all the times.

comment:6 Changed 12 years ago by jackburton

I think I fixed the problem: BeMail calls BTextView::SetFontAndColor(0, LONG_MAX), and the values are never pinned within reasonable limits. I can't either test or commit because my development pc has gone nuts, so I'll attach a diff. If someone can commit this...

Changed 12 years ago by jackburton

Attachment: textview.patch added

Bug Fix

comment:7 Changed 12 years ago by jackburton

Cc: korli@… added

comment:8 Changed 12 years ago by axeld

Resolution: fixed
Status: assignedclosed

That did the trick. Fixed in hrev19169.

Note: See TracTickets for help on using tickets.