Opened 7 years ago

Closed 7 years ago

#8860 closed bug (fixed)

app_server can mark windows as minimized when they are showing

Reported by: leavengood Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: workspaces Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Once they are in this state they cannot be actually minimized (hidden) again.

Steps to reproduce:

  1. Open a window, such a home in Tracker.
  2. Open the Workspaces applet.
  3. While hold CTRL and SHIFT, click the window in Workspaces. This will hide it. Don't move the mouse!
  4. While keeping the mouse in the same location, hold CTRL and click again. This will bring the window to the front, essentially un-minimizing it.

You now have a window that cannot be minimized again. Not by double clicking the title, not by using the deskbar, nor by CTRL-SHIFT-clicking again in Workspaces.

I think the issue is the minimized flag is not unset when the window is brought to the front.

And obviously it is a bug in the WorkspacesView in the app_server to bring minimized windows to the front like that. But the app_server should not let windows get in this state.

Change History (1)

comment:1 Changed 7 years ago by leavengood

Resolution: fixed
Status: newclosed

Turns out this is specific to how Workspaces was showing minimized windows and is fixed because of hrev44512.

Note: See TracTickets for help on using tickets.