Opened 7 years ago

Closed 6 years ago

#8897 closed bug (fixed)

lanyrd.com crashes web+

Reported by: mmadia Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev44483 gcc2h

http://lanyrd.com

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 1672 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/common/lib/libwtf.so...done.
Loaded symbols for /boot/common/lib/libwtf.so
Reading symbols from /boot/common/lib/libjavascriptcore.so...done.
Loaded symbols for /boot/common/lib/libjavascriptcore.so
Reading symbols from /boot/common/lib/libwebcore.so...done.
Loaded symbols for /boot/common/lib/libwebcore.so
Reading symbols from /boot/common/lib/libwebkit.so...done.
Loaded symbols for /boot/common/lib/libwebkit.so
Reading symbols from /boot/system/lib/gcc4/libstdc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libstdc++.so
Reading symbols from /boot/system/lib/gcc4/libbe.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbe.so
Reading symbols from /boot/system/lib/gcc4/libnetwork.so...done.
Loaded symbols for /boot/system/lib/gcc4/libnetwork.so
Reading symbols from /boot/system/lib/gcc4/libtracker.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtracker.so
Reading symbols from /boot/system/lib/gcc4/libtranslation.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtranslation.so
Reading symbols from /boot/system/lib/gcc4/libroot.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot.so
Reading symbols from /boot/system/lib/gcc4/libicuuc.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicuuc.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicudata.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicudata.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicui18n.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicui18n.so.48.1.1
Reading symbols from /boot/common/lib/libcurl.so.4.2.0...done.
Loaded symbols for /boot/common/lib/libcurl.so.4.2.0
Reading symbols from /boot/system/lib/gcc4/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/gcc4/libjpeg.so.8.0
Reading symbols from /boot/system/lib/gcc4/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/gcc4/libpng.so.1.4
Reading symbols from /boot/common/lib/libsqlite3.so.0.8.6...done.
Loaded symbols for /boot/common/lib/libsqlite3.so.0.8.6
Reading symbols from /boot/common/lib/libxml2.so.2.8.0...done.
Loaded symbols for /boot/common/lib/libxml2.so.2.8.0
Reading symbols from /boot/system/lib/gcc4/libz.so.1...done.
Loaded symbols for /boot/system/lib/gcc4/libz.so.1
Reading symbols from /boot/system/lib/gcc4/libbsd.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbsd.so
Reading symbols from /boot/system/lib/gcc4/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtextencoding.so
Reading symbols from /boot/system/lib/gcc4/libicuio.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicuio.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicule.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicule.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libiculx.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libiculx.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicutu.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicutu.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libsupc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libsupc++.so
Reading symbols from /boot/common/lib/libssl.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libssl.so.1.0.0
Reading symbols from /boot/common/lib/libcrypto.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libcrypto.so.1.0.0
Reading symbols from /boot/common/lib/liblzma.so.5.0.1...done.
Loaded symbols for /boot/common/lib/liblzma.so.5.0.1
Reading symbols from /boot/common/lib/libiconv.so.2.5.0...done.
Loaded symbols for /boot/common/lib/libiconv.so.2.5.0
Reading symbols from /boot/system/lib/gcc4/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/WebPositive http://lanyrd.com/2012/haikudownunder/ (1672) thread WebPositive (1672)]
0x0141ee6f in WebCore::GlyphPageTreeNode::getChild ()
   from /boot/common/lib/libwebcore.so
(gdb) bt
#0  0x0141ee6f in WebCore::GlyphPageTreeNode::getChild ()
   from /boot/common/lib/libwebcore.so
#1  0x0141f25c in WebCore::GlyphPageTreeNode::initializePage ()
   from /boot/common/lib/libwebcore.so
#2  0x0141f0a8 in WebCore::GlyphPageTreeNode::getChild ()
   from /boot/common/lib/libwebcore.so
#3  0x1875c558 in ?? ()
#4  0x1878d050 in ?? ()
#5  0x00000000 in ?? ()
#6  0x00000000 in ?? ()
#7  0x00000000 in ?? ()
#8  0x1875c478 in ?? ()
#9  0x1878d050 in ?? ()
#10 0x187896e0 in ?? ()
#11 0x187897f0 in ?? ()
#12 0x01d37d90 in ?? () from /boot/system/lib/gcc4/libbe.so
#13 0x1878d050 in ?? ()
#14 0x0000003f in ?? ()
#15 0x01d449e0 in be_app () from /boot/system/lib/gcc4/libbe.so
#16 0xffffffff in ?? ()
#17 0x7fffffff in ?? ()
#18 0x0195c214 in ?? () from /boot/common/lib/libwebcore.so
#19 0x1878e1c8 in ?? ()
#20 0x186e16ec in ?? ()
#21 0x7ffecae8 in ?? ()
#22 0x014143bc in WebCore::Font::glyphDataAndPageForCharacter ()
   from /boot/common/lib/libwebcore.so
#23 0x1875c468 in ?? ()
#24 0x1878d050 in ?? ()
#25 0x00000000 in ?? ()
#26 0x1878e1c8 in ?? ()
---Type <return> to continue, or q <return> to quit---
#27 0x1878a198 in ?? ()
#28 0x00000000 in ?? ()
#29 0x7ffecac8 in ?? ()
#30 0x01fbdda9 in BPrivate::processHeap::free ()
   from /boot/system/lib/gcc4/libroot.so
Previous frame inner to this frame (corrupt stack?)
(gdb) 

Change History (1)

comment:1 by pulkomandy, 6 years ago

Resolution: fixed
Status: newclosed

Can't reproduce anymore.

Note: See TracTickets for help on using tickets.