Opened 13 years ago

Closed 13 years ago

#890 closed bug (fixed)

[Deskbar] icons are broken for supertypes

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Application Kit Version: R1/pre-alpha1
Keywords: Cc: axeld
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

comman line app have broken icons in Deskbar. To reproduce, launch top from tracker.

Change History (8)

comment:1 by axeld, 13 years ago

Owner: changed from axeld to stippi

comment:2 by johndrinkwater, 13 years ago

Summary: [Deskbar] cli icons are broken[Deskbar] icons are broken for supertypes

Doesn't affect just CLI applications; anything without a custom icon that relies on the parent type's icon has this issue (like Playground)

comment:3 by jackburton, 13 years ago

Cc: axeld added

I think I found the problem. TBarApp::AddTeam() uses BBitmap::SetBits() and passes B_RGB32 as colorspace parameter, but SetBits() interprets that as B_RGB24_BIG (to mimic R5's behaviour, AFAIK). Passing B_RGBA32 instead should be fine.

in reply to:  3 comment:4 by jackburton, 13 years ago

Replying to jackburton:

I think I found the problem. TBarApp::AddTeam() uses BBitmap::SetBits() and passes B_RGB32 as colorspace parameter, but SetBits() interprets that as B_RGB24_BIG (to mimic R5's behaviour, AFAIK). Passing B_RGBA32 instead should be fine.

Actually it already passes RGBA32. looks like the problem was elsewhere. Should be fixed in rev 19420, please review.

comment:5 by axeld, 13 years ago

Stefano, in case you missed it: please always write hrev19420, so Trac can pick it up and create a link to the revision.

in reply to:  5 comment:6 by jackburton, 13 years ago

Replying to axeld:

Stefano, in case you missed it: please always write hrev19420, so Trac can pick it up and create a link to the revision.

Yes, sorry, I forgot about that. What about the change ? Does it look correct ? At least I can't reproduce this bug anymore.

comment:7 by jackburton, 13 years ago

Also, the generic application icon in deskbar is still the old style 8 bit icon (and that's why my change fixed the problem)

comment:8 by jackburton, 13 years ago

Resolution: fixed
Status: newclosed

Original bug is fixed, I'll open a new bug for the 8 bit icon problem

Note: See TracTickets for help on using tickets.