Opened 7 years ago

Last modified 3 years ago

#8907 new bug

(Gutenprint) can't select Epson Stylus DX4400

Reported by: Morbid Owned by: phoudoin
Priority: normal Milestone: R1
Component: Drivers/Printers Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

See Screenshot with included description!

Attachments (4)

screenshot1.png (129.9 KB ) - added by Morbid 7 years ago.
screenshot2.png (120.9 KB ) - added by Morbid 7 years ago.
listusb -v (12.8 KB ) - added by Morbid 7 years ago.
Terminal_dev_bus_usb (1.8 KB ) - added by Morbid 7 years ago.

Download all attachments as: .zip

Change History (27)

by Morbid, 7 years ago

Attachment: screenshot1.png added

comment:1 by phoudoin, 7 years ago

Seems related to localisation, but I've yet to figure the details...

comment:2 by Morbid, 7 years ago

That was my first Idea, too! Tested with german and english on my PC and both the same result. Than i tried on my Uncles PC, also an Epson-Printer-Model (CX....), but there was no Problem.

comment:3 by Morbid, 7 years ago

And on my Uncles PC are original Cartridges. So i expect: maybe the Refill-Cartridges in my Printer!?! But the Moment i didn't have original Cartridges for DX4400 Printer.

by Morbid, 7 years ago

Attachment: screenshot2.png added

comment:4 by Morbid, 7 years ago

On Screenshot2.png tried to select DX4400 and want to make a Test-Print via StyleEdit. The Printer shuts down and the Printstatus-Window stay on the screen.

comment:5 by phoudoin, 7 years ago

I've changed my mind, and now suspect an USB string language issue. Could you attach an listusb -v and a listusb -v /dev/bus/usb/path/to/your/printer, to see if the strings are retrieved without issue by listusb tool?

comment:6 by phoudoin, 7 years ago

Could be that your USB printer don't support 0 as default string descriptor language, and instead return the "Language Error" string instead. Is it an old USB printer?

by Morbid, 7 years ago

Attachment: listusb -v added

comment:7 by phoudoin, 7 years ago

Confirmed that the "Language Error" string is actually returned by the printer itself: http://www.sane-project.org/unsupported/epson-stylus-dx4450.html

comment:8 by anevilyak, 7 years ago

Interestingly I don't see the printer listed at all in that output.

comment:9 by phoudoin, 7 years ago

Indeed, no trace of your printer. Mostly because this printer needs to have a firmware loaded first to publish and behave like a fully working USB printer (or scanner, for that matter) :-(

https://bbs.archlinux.org/viewtopic.php?id=77802]

comment:10 by Morbid, 7 years ago

Sorry for waiting! Was a little confused! I'm new to Haiku! Where can i find /dev/bus/usb/? Is it under home, common or system folder?

comment:11 by anevilyak, 7 years ago

/dev is its own top level directory, it's simply not shown in Tracker (since one normally doesn't need to care about it), but you can get to it in Terminal.

comment:12 by Morbid, 7 years ago

Thanks! Will try it, and yes it's an old printer. Aprox. 5 or 6 Years old.

comment:13 by Morbid, 7 years ago

Didn't seen a printer there! Btw to boot up Haiku i use an USB-Stick!

by Morbid, 7 years ago

Attachment: Terminal_dev_bus_usb added

comment:14 by Morbid, 7 years ago

Have to restart Haiku! Something was blocking the system! -> listusb -v /dev/bus/usb/0/1 in file Terminal_dev_bus_usb.

comment:15 by phoudoin, 7 years ago

The "Language Error Language Error" is, as suspected, returned by your printer as manufacturer and product strings, hence the USB port name entry. Not a sexy port name indeed, but as we have no way to detect the descriptor string requests failed, we can't even fallback to USB IDs static table to find a better port name - a feature which is not yet implemented anyway ;-).

Anyway, this should not block the port actual usage, as that's just a naming issue. If you select this broken port name, does it actually print on it?

I will be really surprised if it does, as I fear that such printer actually needs a firmware to be loaded over USB first in order to do the job, and the unset string descriptor is just a symptom of that.

Last edited 7 years ago by phoudoin (previous) (diff)

comment:16 by Morbid, 7 years ago

No DX4400 did'nt print. New try with selecting in Gutenprint DX4450. Result was that the Printer starting to Print and after aprox. 3 seconds device was shutting down again!

comment:17 by Morbid, 7 years ago

Cause of blocking Haiku was that i can't interrupt with STRG-ALT-DEL with force cancel Printer -Service. After restart Haiku holds the Printer-Task. The hole system hangs up so i had to restart again.

comment:18 by Morbid, 7 years ago

Understand what you're meaning! Thanks for commitment and bye for now! Just one question at last: Are there plans to port CUPS to Haiku?

comment:19 by Disreali, 7 years ago

There are two separate ports of CUPS for Haiku over on http://dev.osdrawer.net. No idea if either actually work.

comment:20 by Morbid, 7 years ago

Thanks! I asked because i have another Printer (HP Deskjet D1460)that will not supported by Gutenprint. Getting a PPD-File from HP and copied it in the Cups-Folder under ZETA and it works.

comment:21 by phoudoin, 7 years ago

Component: PrintingDrivers/Printers

comment:22 by vidrep, 3 years ago

Can this be tested again with the latest Gutenprint drivers (5.2.11)?

comment:23 by Morbid, 3 years ago

Sorry, can not be tested by me anymore because Epson DX4400 and HP Deskjet D1460 Printers are scraped. Thx.

Note: See TracTickets for help on using tickets.