Opened 7 years ago

Closed 5 years ago

#8915 closed bug (duplicate)

I can no-longer use the keyboard to change the brightness.

Reported by: bbjimmy Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I can no-longer change the brightness or turn on/off the wireless interface from the keyboard on my asus eeepc. This is a regression. It worked some time in the past, and I just noticed it when my wife turned off the wireless card in Windows and I could not turn it on in HAIKU.

There is a forum thread on the issue:

https://www.haiku-os.org/community/forum/lowering_brightness

Change History (7)

comment:1 Changed 7 years ago by anevilyak

Component: - GeneralDrivers/ACPI
Owner: changed from nobody to tqh
Status: newassigned
Version: R1/alpha3R1/Development

comment:2 Changed 5 years ago by bbjimmy

This ticket can be closed, the issue has been resolved in recent nightly images.

comment:3 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed

comment:4 Changed 5 years ago by Giova84

Resolution: fixed
Status: closedreopened

comment:5 Changed 5 years ago by Giova84

I'm on hrev46523 and i can't still change brightness/other things using the keyboard on my laptop. Was possible long time ago.

comment:6 Changed 5 years ago by Giova84

Update: if on my laptop i press the fn key + F7/F8 (keys to change brightness), as i've said, nothing happens. But inside the syslog i can read:

KERN: [ACPI Debug] String [0x0B] "FN+F8 Event"
KERN: [ACPI Debug] String [0x0B] "FN+F7 Event"
KERN: [ACPI Debug] String KERN [0x0B] "FN+F7 Event"

What that means?

comment:7 Changed 5 years ago by tqh

Resolution: duplicate
Status: reopenedclosed

This is a duplicate of #8258.

The only reason it worked before was that BIOS was handling your brightness, so it is not really a regression, but an unimplemented feature. BIOS handling gets disabled when ACPI starts. A driver for handling brightness has never been fully implemented. It's not very complicated, while it is on my TODO I can't do that until I have Haiku working on my laptop.

The debug output I'm not sure about, I think Jerome added some debugging info.

Note: See TracTickets for help on using tickets.