Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#8921 closed bug (no change required)

TCP connection stalls when talking to specific SMTP mail server

Reported by: zooey Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/TCP Version: R1/Development
Keywords: Cc: phoudoin
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Recently, something has probably changed in the internal network of my standard e-mail provider, which causes both Beam and MDR to no longer be able to send e-mails via that provider's SMTP server (mail.hirschkaefer.de).

Inspection with Wireshark shows that as soon as the mail client sends e-mail data (via the DATA command), Haiku's TCP protocol implementation sends out three segments of 1448 bytes, filling the TCP window. After that, the connections is idle for a moment, then Haiku proceeds to retransmit the first of these segments several times. From that state, the connection never recovers (Haiku keeps trying retransmits without any success), finally causing the server to close the connection.

The TCP implementation of Linux does not seem to have any problem to talk to the same SMTP server.

Upon request, I can provide username and password to connect to the SMTP server for debugging purposes.

Change History (6)

comment:1 by axeld, 8 years ago

It might be the same bug that prevents me (most of the time) to upload something to Strato. I have the suspicion that Haiku does not correctly handle receive segment in certain situations -- since the upload to Strato is rather slow, I assume it happens when received packets are reordered.

Anyway, if it's the same bug, it already bugs me since a few years, but I didn't yet find the time to look into it.

comment:2 by phoudoin, 7 years ago

Cc: phoudoin added

comment:3 by mmlr, 5 years ago

If these were still reproducible issues, the changes in hrev49502 (specifically da8fbe0 and 5f77490) might solve them. Testing before/after this revision to verify would be nice.

in reply to:  3 comment:4 by zooey, 5 years ago

Replying to mmlr:

If these were still reproducible issues, the changes in hrev49502 (specifically da8fbe0 and 5f77490) might solve them. Testing before/after this revision to verify would be nice.

Unfortunately (for this issue, not for me personally), I have switched internet access providers by now and as a result can no longer reproduce this problem.

comment:5 by pulkomandy, 5 years ago

Resolution: no change required
Status: newclosed

Maybe it's better to close the ticket for now then. Please reopen if you find other servers with similar problems.

comment:6 by ttcoder, 5 years ago

Some not-so-anecdotal data points that might be relevant:

dsuden has updated the machine that broadcasts FairHarborRadio to 49505, and apparently it works again now (in the past few months he sadly had to give up on streaming our flagship radio because it caused some sort of congestion or other network issue that disabled his router and VoIP service after a few hours). I also suggested him to try BeMail again (previously he said it was pointless because SMTP "never works no matter the settings"). As to me, I sometimes have trouble uploading my builds to Dane using curl; we'll see if it improves too.

Long story short, a few more days of testing and someone might get mad props/kudos :-)

Note: See TracTickets for help on using tickets.