Opened 7 years ago

Closed 6 years ago

#8930 closed bug (fixed)

RTL8111/8168b

Reported by: mpxlbs Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/TCP Version: R1/Development
Keywords: RTL81xx RTL8168b Cc: grg.gdsr@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Motherboard is a 990FX Sabertooth by Asus with built-in ethernet.

Ethernet driver configures itself using the rtl81xx driver. No errors in logs. Configures and maintains a ready status. Tried both DHCP and Static without luck. I've read somewhere that under Haiku, this driver should normally work, although, in my case it does not.

Attempted patching with the guide in Haikuware (RTL81xx patching), but without any luck.

If needed more info, please don't hesitate to ask. First bug report.

Works under Aros, Linux and Windows (No network chip error).

Tested both the Alpha and master branch. Rev. 44580 and 44584.

Attachments (3)

syslog (130.6 KB ) - added by mpxlbs 7 years ago.
syslog.txt (207.8 KB ) - added by HAL 7 years ago.
Syslog for hrev45189-x86gcc2hybrid
syslog.2 (319.5 KB ) - added by mpxlbs 6 years ago.
hrev45642 - Syslog

Download all attachments as: .zip

Change History (13)

by mpxlbs, 7 years ago

Attachment: syslog added

comment:1 by SeanCollins, 7 years ago

add me to this list, MSI 970a-g46 motherboard, same issue. Returns garbled IP adress in network prefs on my board however. hrev 44744

from listdev

device Network controller (Ethernet controller) [2|0|0]

vendor 10ec: Realtek Semiconductor Co., Ltd. device 8168: RTL8111/8168B PCI Express Gigabit Ethernet controller

Last edited 7 years ago by SeanCollins (previous) (diff)

in reply to:  1 comment:2 by umccullough, 7 years ago

Replying to SeanCollins:

Returns garbled IP adress in network prefs on my board however.

I could be wrong - but I'm thinking the driver has little to do with this part. The layer responsible for obtaining and configuring the IP address is further up in the network stack - so this sounds like some kind of memory corruption going on.

comment:3 by SeanCollins, 7 years ago

I get no link to my local network, router does not report seeing the machine via mac or ip adress, I do see the hardware get loaded. My IP adress is fairly typical behind my router, 192.168.2.1. However network prefs and the network notification do indicate that the device was sucessfully configured

however, network prefs shows the ip adress as 168.0.254.9 or some other such odd ball number. it also reports the netmask as 18.0.0.0

I don't know if this info is helpful or not.I stuff a known works rtl8139 pci card in the machine however in the meantime, if there is any testing I can do to help nail this down, let me know.

comment:4 by umccullough, 7 years ago

If it's 169.254.x.x, that's expected when no DHCP server was found (which I believe you confirmed for me via IRC).

comment:5 by HAL, 7 years ago

I don't know if my problem is exactly the same because my network on board chip is rtl8169 but the symtoms are very similar. I had to wait until the latest FreeBSD 9 driver updates before the chip was detected. Now it it is detected wrongly similar to the symtoms here. This is the bug I reported about no network being detected because of unknown id for chip: #9131 If it is not the driver that is the problem but some type of memory corruption as in comment 2 then my bug has become the same as this. My motherboard is ASUS M5A97 R2.0. I was testing with hrevr1alpha4-44663 in the bug #9131 and hrev45164-x86gcc2hybrid, where the network IP and other addresses were detected like this with DHCP: RTL8169 IP:169.254.0.157 Netmask: 255.255.0.0 Gateway: 192.169.1.1 DNS # 1: 0.0.0.0 DNS # 2: 0.0.0.0 Domain: blank

in reply to:  5 comment:6 by korli, 7 years ago

Replying to HAL:

I don't know if my problem is exactly the same because my network on board chip is rtl8169 but the symtoms are very similar. I had to wait until the latest FreeBSD 9 driver updates before the chip was detected. Now it it is detected wrongly similar to the symtoms here. This is the bug I reported about no network being detected because of unknown id for chip: #9131

Please provide a syslog on a recent nightly.

comment:7 by HAL, 7 years ago

Is a syslog on hrev45164-x86gcc2hybri recent enough?

by HAL, 7 years ago

Attachment: syslog.txt added

Syslog for hrev45189-x86gcc2hybrid

comment:8 by HAL, 7 years ago

I attached a syslog.txt on the latest build. I booted from a USB stick. The DHCP was: IP=169.254.0.157 Gateway=blank DNS #1=0.0.0.0 DNS #2=0.0.0.0 Domain=blank Ethernet controller from lspci command in Ubuntu is: 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 09)

comment:9 by HAL, 6 years ago

Cc: grg.gdsr@… added

by mpxlbs, 6 years ago

Attachment: syslog.2 added

hrev45642 - Syslog

comment:10 by korli, 6 years ago

Resolution: fixed
Status: newclosed

Should be fixed in hrev45925.

Note: See TracTickets for help on using tickets.