Opened 7 years ago

Closed 5 years ago

#8932 closed bug (fixed)

dosfs_unmount -> crash in block_cache_delete

Reported by: czeidler Owned by: korli
Priority: blocker Milestone: R1
Component: File Systems/FAT Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is an easy to reproduce kernel crash, hope this is not a duplicate. Just mount a usb stick (mine was fat) and then hard pull it. The backtrace goes to dosfs_unmount and block_cache_delete.

Change History (4)

comment:2 by scottmc, 7 years ago

Milestone: R1/alpha4R1

comment:3 by oco, 6 years ago

I was not able to reproduce this problem with a fat partition on current nightly (PM, revision 38c62df) and on a one year old revision (hrev44660). For me, the only remaining "problem" is if there is writing occuring at the time of pulling. I think this last case is covered by #6683.

comment:4 by luroh, 5 years ago

Resolution: fixed
Status: newclosed

hrev49113, I can't repeat this either. Assuming fixed.

Note: See TracTickets for help on using tickets.