Opened 7 years ago

Closed 7 years ago

#8938 closed bug (fixed)

Tracking Ticket for r1alpha4 OptionalPackages that have problems

Reported by: scottmc Owned by: scottmc
Priority: normal Milestone: R1/alpha4
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #8941, #8947 Blocking:
Has a Patch: no Platform: All

Description

If you find any problems with OptionalPackages for r1alpha4 add a comment to this tracking ticket.

Change History (10)

comment:1 by scottmc, 7 years ago

Add alternate freetype package to enable sub-pixel rendering.

Several Packages still put some files in common/share: flex, rsync, ruby, transmission, others?

comment:2 by dcatt, 7 years ago

The one thing I have noticed about installoptionalpackage is that it is putting a major load on the CPU during installation of an app as well as generating the list afterwards. Not sure if I noticed the same symptoms with Haiku A3 (I'm currently running Haiku A4: hrevr1alpha44577)

comment:3 by luroh, 7 years ago

Blocked By: 8941, 8947 added

comment:4 by scottmc, 7 years ago

Need to resolve these and then rebuild the OpenSSH gcc2 and gcc4 packages
http://ports.haiku-files.org/ticket/633
http://ports.haiku-files.org/ticket/634

comment:5 by scottmc, 7 years ago

Milestone: R1R1/alpha4

comment:7 by luroh, 7 years ago

NetSurf currently doesn't work on either master or alpha branch.

comment:8 by scottmc, 7 years ago

I have uploaded new builds of vim, openssh, caya & it's gpl-protocols, and ocaml, just need to get them tested out before I push them. Might get to them in the next day or so. Netsurf will only happen if someone else digs into it...

comment:9 by scottmc, 7 years ago

vim, caya and ocaml have now been updated. I also updated openssh, but haven't checked to see if it addressed both of Axel's concerns, specifically http://ports.haiku-files.org/ticket/634 .

Also we could still use freshened gcc2 and gcc4 packages.

comment:10 by scottmc, 7 years ago

Resolution: fixed
Status: newclosed

gcc2 and gcc4 packages have now been updated and a fresh gcc4 build of perl added, this ticket can be considered complete.

Note: See TracTickets for help on using tickets.