Opened 13 years ago

Closed 13 years ago

#895 closed bug (fixed)

system lock when with uhci usb

Reported by: korli Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

The system locks when loading the usb stack.

Reproducable on QEmu with when using "-usb -usbdevice mouse"

Attachments (1)

seriallog.txt (69.1 KB) - added by korli 13 years ago.
serial log with usb tracing activated

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by korli

Attachment: seriallog.txt added

serial log with usb tracing activated

comment:1 Changed 13 years ago by korli

About the serial log, I added a kernel_debugger() call to the latest line before the system lock happens.

comment:2 Changed 13 years ago by mmlr

Which version of QEMU did you use to reproduce this? I wasn't able to reproduce it over here. The problem is that the BusManager tries to configure the device, but the device doesn't responde to the setup transfer. Since transfer timeouts are not yet implemented, the system hangs. You could try to change the acquire_sem() call in Pipe.cpp ControlPipe::SendRequest() to a acquire_sem_etc() with a timeout. I will implement this change later today if I find the time.

comment:3 Changed 13 years ago by korli

QEmu 0.8.2 on Linux. And adding a timeout didn't help much, sorry.

comment:4 Changed 13 years ago by korli

Resolution: fixed
Status: newclosed

Fixed here in revision 19250

Note: See TracTickets for help on using tickets.