Opened 7 years ago

Closed 7 years ago

#8992 closed bug (fixed)

formatting a 3 TB partition makes it a ~1 TB partition

Reported by: luroh Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev44645, gcc2. I'm attaching a fresh VirtualBox 3 TB GPT disk containing a single unformatted partition. Format the partition using 'mkfs' or 'mkdos', and notice its mountable size being only 881.69 GiB.

Attachments (1)

3TB_fresh.vdi.zip (14.3 KB) - added by luroh 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by luroh

Attachment: 3TB_fresh.vdi.zip added

comment:1 Changed 7 years ago by oco

It seems there is also a problem while partitioning smaller disk.

On a fresh 8 Go disk under Virtual Box, using ISO hrevr1alpha4-44606, i create an Intel partition map, then a 8 Go partition. After formating using BFS and installing Haiku, i was unable to boot. After rebooting with the ISO again, i found that the partition was only 2 Go large with 6 Go of free space.

comment:2 Changed 7 years ago by oco

Well, i was not able to reproduce it on a different virtual machine (but dynamic size drive instead of a fix one). Strange, because i have tried two times with the previous machine.

comment:3 Changed 7 years ago by axeld

Owner: changed from bonefish to axeld
Status: newin-progress

comment:4 Changed 7 years ago by axeld

Component: Partitioning SystemsSystem/Kernel
Resolution: fixed
Status: in-progressclosed

Fixed in hrev44684.

Note: See TracTickets for help on using tickets.