Opened 7 years ago

Closed 7 years ago

#9034 closed bug (fixed)

Installoptionalpackages Segment Violation

Reported by: HAL Owned by: nobody
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: crash segment violation Cc: HAL
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Installoptionalpackage crashed when I typed

installoptionalpackage -f

in terminal to get a list of inatallable packages.

Steps to reproduce:

  1. In terminal type installoptionalpackage -f
  2. Press Enter.

This results in gdb and I have a back trace. I get similar crashes too when trying to install any application. If I don't click the button to show the gdb but OK instead, nothing gets installed. Here is an example:

installoptionalpackage -a -s SampleStudio
/bin/installoptionalpackage: line 464: availablePackages[${pkg}]: bad array subscript
... no packages need to be installed.

If you wish to re-install a package, run these two commands
    rm /boot/common/data/optional-packages/OptionalPackageNames
    open /boot/common/data/optional-packages/InstalledPackages
and delete the line containing the package name(s).

Not proceeding with installation.
~> rm /boot/common/data/optional-packages/OptionalPackageNames

When I rm /boot/common/data/optional-packages/OptionalPackageNames it does not make any difference when I try again. Also doing this: open /boot/common/data/optional-packages/InstalledPackages and delete the line containing the package name(s), the package name does not exist there anyway.
I was testing in hrev1alpha4-44597.

Attachments (1)

Installoptionalpackages Crash.txt (31.3 KB ) - added by HAL 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 by HAL, 7 years ago

Component: - GeneralApplications
Keywords: crash segment violation added

comment:2 by HAL, 7 years ago

I do not know how I attached two files. All I did was upload installoptionalpackages Crash.txt and immediately clicked it to view. After that clicked the back button on webpositive and there were two files attached. One of them can be deleted.

comment:3 by diver, 7 years ago

Description: modified (diff)
Version: R1/alpha3R1/Development

comment:4 by luroh, 7 years ago

Please use a newer version when testing, hrev1alpha4-44597 is two weeks old and a lot has happened since then.

comment:5 by HAL, 7 years ago

I tested with hrev1alpha4-44612 and was unable to reproduce. Still has other problem. Wont download everything in a list. This is another bug though.

comment:6 by luroh, 7 years ago

Resolution: fixed
Status: newclosed

Closing, thanks for checking!

Note: See TracTickets for help on using tickets.