Opened 7 years ago

Closed 7 years ago

#9043 closed bug (fixed)

Regression: Haiku boots in Vesa-Mode on AMD Radeon HD 6320

Reported by: blutigerWilliam Owned by: kallisti5
Priority: normal Milestone: R1/alpha4
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku boots in VESA-Mode with a resolution of 1024x768. It seems like my AMD Radeon HD 6320 isn't recognized any more. Build: hrevr1alpha4-44621. Worked fine with hrev44459.

Attachments (3)

syslog.txt (145.0 KB ) - added by blutigerWilliam 7 years ago.
syslog_hrev44459.txt (158.8 KB ) - added by blutigerWilliam 7 years ago.
radeon_hd_r1a4.diff (1.3 KB ) - added by kallisti5 7 years ago.
un-disable working cards.

Download all attachments as: .zip

Change History (13)

by blutigerWilliam, 7 years ago

Attachment: syslog.txt added

comment:1 by anevilyak, 7 years ago

Component: - GeneralDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5

comment:2 by kallisti5, 7 years ago

I dropped many of the HD 6xxx laptop chipsets because a majority of them didn't work at this time(including the one in my laptop)... Strange that yours did work.

The goal of disabling mobile 6xxx chipsets in favor of stability vs new users getting stuck with just a "black screen" when they boot.

Do you have any of the syslogs from hrev44459? Do you know if your 6320 has a NUTMEG or TRAVIS encoder? (the syslogs for radeon_hd should of said)

Anyway, this regression was on purpose.

by blutigerWilliam, 7 years ago

Attachment: syslog_hrev44459.txt added

comment:3 by blutigerWilliam, 7 years ago

Made a new syslog with hrev44459 and attached it. I hope it is useful...

by kallisti5, 7 years ago

Attachment: radeon_hd_r1a4.diff added

un-disable working cards.

comment:4 by kallisti5, 7 years ago

Has a Patch: set

comment:5 by kallisti5, 7 years ago

Has a Patch: unset
Milestone: R1R1/alpha4

pushing to get this fix included in R1A4

comment:6 by kallisti5, 7 years ago

It seems that only the sumo and sumo2 chipsets have the DP bridge-only configuration. Palm *can* have DP bridges, but it isn't a requirement (up to the vendor)... thus users have a shot at them working.

If your Radeon HD palm gpu has a DP-bridge and doesn't work:

  • boot to safe video mode
  • remove radeon_hd from /boot/system/add-ons/kernel/drivers/bin/
  • reboot

comment:7 by blutigerWilliam, 7 years ago

Sorry, did you apply a change? Tested it with the latest nightly(hrevr1alpha4-44630), but it still boots in VESA-Mode...

comment:8 by umccullough, 7 years ago

Has a Patch: set

reset "patch" flag that got turned off by accident

comment:9 by kallisti5, 7 years ago

Has a Patch: unset

picked for R1A4 in hrevr1alpha4-44640

  • Sumo are the only APU's with DP-only bridges
  • While Palm *may* have DP bridges, it's not a requirement. (up to the vendor)
  • Palm chipsets with DP bridges will need to boot vesa and remove radeon_hd for now.

comment:10 by kallisti5, 7 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.