Opened 7 years ago

Closed 7 years ago

#9060 closed bug (duplicate)

File-list read error from NTFS USB HDD

Reported by: dsjonny Owned by: 3dEyes
Priority: normal Milestone: R1
Component: File Systems/NTFS Version: R1/Development
Keywords: Cc:
Blocked By: #4974 Blocking:
Has a Patch: no Platform: All

Description

I have a problem with my Samsung M2 320GB USB HDD. When I mount it and open it like with the Tracker, than I see some folders and files, but many entries are missing. But, the Tracker try to load the loe list from the device. At this time, all the CPU's are used about 10-20%, and in about every 15s the mouse "freeze".

I use the alpha4-44629 image. The HDD was formatted under Windows 7 to NTFS.

~/Desktop> listusb
...
04e8:60b2 /dev/bus/usb/0/0/3 "Samsung Electronics Co., Ltd" "Samsung M2 Portable" ver. 0000
...
~/Desktop> mountvolume
Volume                           File System                   Size Mounted At (Device)
--------------------------------------------------------------------------------------------
Rendszer számára fenntartott   Windows NT File System      350.0M (scsi/0/5/0/0)
Windows 8                        Windows NT File System       57.3G (scsi/0/5/0/1)
Haiku                            Be File System                2.0G /boot  (scsi/0/5/0/2)
SAMSUNG                          Windows NT File System      298.1G /SAMSUNG  (usb/0/0/0)

I also tried to access to the disk from Terminal, but the problem is the same.

Maybe there is a special name/entry in the folder what Haiku cannot understand? I use hungarian characters in the file/filder names. First I think this is the problem, but when I enter to a folder, there is no problem.

I have no idea what information need to provide for this problem. So please ask is you need something else.

Change History (2)

comment:1 by anevilyak, 7 years ago

Possibly a duplicate of #4974 and/or #7573.

comment:2 by luroh, 7 years ago

Blocked By: 4974 added
Milestone: R1/alpha4R1
Resolution: duplicate
Status: newclosed
Version: R1/alpha3R1/Development
Note: See TracTickets for help on using tickets.