Opened 7 years ago

Closed 5 years ago

#9063 closed bug (fixed)

Web+ interface doesn't handle IDN domains

Reported by: przemub Owned by: pulkomandy
Priority: low Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When I tried to enter ąćęłńóśźż.pl site by clicking hyperlink, it was converted to http://xn--kda9ag6e8jma6nxjsa.pl/ and displayed correctly.

But in address bar URL is shown in ASCII (xn--...) what does not look OK. More importantly, I cannot enter this site through entering its address in bar, because browser returns:

Error loading http://ąćęłńóśźż.pl: URL cannot be shown

Change History (6)

comment:1 by dsjonny, 7 years ago

I got this too for http://www.magyarország.hu/

comment:2 by pulkomandy, 6 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #7272.

comment:3 by pulkomandy, 6 years ago

Resolution: duplicate
Status: closedreopened

Actually, the fix to #7272 does not completely solve this. Reopening.

comment:4 by pulkomandy, 6 years ago

Owner: changed from leavengood to pulkomandy
Status: reopenedin-progress

comment:5 by pulkomandy, 6 years ago

https://github.com/haiku/webkit/commit/3a145976f37941e0431879094fc178184c594fe9 implements the displaying part.

Typing or pasting ​http://ąćęłńóśźż.pl will work, but for some reason ​ąćęłńóśźż.pl will not. Still investigating...

comment:6 by pulkomandy, 5 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in https://github.com/haiku/webkit/commit/44a7262b6591846d2fbcba80bc36201fa0c38d9e. This will be part of the next haikuwebkit release.

Note: See TracTickets for help on using tickets.