Opened 13 years ago

Closed 13 years ago

#907 closed bug (fixed)

Drag to VLC 0.8.5 causes vm_page_fault

Reported by: darkwyrm Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

VLC starts fine now, but I dragged one of the Memorial Day videos to it from Tracker and it caused a vm_page_fault. Stack crawl attached.

Attachments (2)

DragMemorialDayToVLCBug.png (32.7 KB) - added by darkwyrm 13 years ago.
SecondVLCError.PNG (28.1 KB) - added by darkwyrm 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by darkwyrm

Attachment: DragMemorialDayToVLCBug.png added

comment:1 Changed 13 years ago by axeld

This doesn't look like a VLC specific problem. Can you reproduce this at will? (I suppose not)

comment:2 Changed 13 years ago by darkwyrm

I double checked the bug, and I can reproduce it... sort of. It's not consistent. 1) Boot Haiku in VMWare (using hrev19048) 2) Open folder for VLC and folder for movie 3) Drag movie to VLC.

One of two things happens: either it quits without a word or it causes the vm_page_fault or it quits (aborts?) without so much as a word. If it quits without a word, starting VLC and then dragging the movie to it causes a trip to KDL with a different error, which I've attached a screenshot of also.

While I now know that the movie is not actually supported by VLC, it should not be able to bring down the entire system.\

Changed 13 years ago by darkwyrm

Attachment: SecondVLCError.PNG added

comment:3 Changed 13 years ago by axeld

I tested on real hardware (I don't even have VMware), and I cannot reproduce this at all. Are the movies on CD, or have you copied them to the hard drive? Both videos play fine with VLC (there is no video, only audio, though). I tested both, VLC 0.8.4a, and 0.8.5.

comment:4 Changed 13 years ago by darkwyrm

Resolution: fixed
Status: newclosed

The movies are on the disk with the rest of the installation. I just did the same test with hrev19072 a moment ago under both VMWare and on real hardware. On real hardware, I couldn't reproduce the problem. The funny thing is that when I attempted it under VMWare, it completely hung the VM. I restarted the VM and tried it again and my Windows installation did an immediate reboot. Somehow I have a feeling that there is more at work here than problems in Haiku -- probably a combination of VMWare and general goofiness on my (somewhat) ailing development box, so I'm closing this bug.

Note: See TracTickets for help on using tickets.