Opened 7 years ago

Closed 7 years ago

#9079 closed bug (no change required)

Workaround for broken marvell_yukon driver (r1a4 only)

Reported by: luroh Owned by: kallisti5
Priority: critical Milestone: R1/alpha4
Component: Drivers/Network/marvell_yukon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

R1/Alpha4 only.

As reported in #8454, marvell_yukon hangs the system, making it impossible to download or even copy another driver in place. I am attaching a couple of patches that let us replace the marvell_yukon driver with an older working binary version at build time. It's a temporary workaround and it may not be pretty either, but it should get the job done for r1a4.

Attachments (3)

0001-Add-binary-marvell_yukon-drivers-for-gcc2-and-gcc4-f.patch (153.4 KB) - added by luroh 7 years ago.
0002-Replace-broken-marvell_yukon-driver-with-pre-compile.patch (1.8 KB) - added by luroh 7 years ago.
0003-Disable-Marvell-Yukon-driver-for-R1A4-see-9079-for-d.patch (1.1 KB) - added by jscipione 7 years ago.
Patch that just removes the Marvell Yukon driver from the image for R1A4

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by luroh

Has a Patch: set

Changed 7 years ago by jscipione

Patch that just removes the Marvell Yukon driver from the image for R1A4

comment:2 Changed 7 years ago by kallisti5

Priority: normalcritical

Lets just remove the Yukon driver if no solution is found by mid-BeGeistert

Last edited 7 years ago by kallisti5 (previous) (diff)

comment:3 Changed 7 years ago by kallisti5

Resolution: no change required
Status: newclosed

A solution was found in #8454

Note: See TracTickets for help on using tickets.