Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9117 closed bug (invalid)

Unable to start dosbox 0.74 on hrev1alpha4-44674

Reported by: Giova84 Owned by: bonefish
Priority: normal Milestone: R1
Component: System/runtime_loader Version: R1/Development
Keywords: Unable to start dosbox 0.74 on hrev1alpha4-44674 Cc:
Blocked By: Blocking:
Platform: x86

Description

On hrev44563 i was able to run DosBox (if I copy libstdc++.so from Alpha3, because without libstdc++.so from Alpha3, DosBox always exit with an error) Today i have installed hrev1alpha4-44674 but now DosBox exit with an error again, also if i copy the old libstdc++.so from Alpha3.

Output of bt:

[Switching to team /boot/apps/DOSBox/dosbox (56589) thread dosbox (56589)]
0x02d82bd4 in std::locale::operator= () from /boot/system/lib/gcc4/libstdc++.so
(gdb) bt
#0  0x02d82bd4 in std::locale::operator= () from /boot/system/lib/gcc4/libstdc++.so
#1  0x02d822c2 in std::ios_base::_M_init () from /boot/system/lib/gcc4/libstdc++.so
#2  0x02d97c81 in std::basic_ios<char, std::char_traits<char> >::init ()
   from /boot/system/lib/gcc4/libstdc++.so
#3  0x003d4506 in Config::ParseConfigFile ()
#4  0x00302f7c in main ()
(gdb)

Output of bt with libstdc++.so from Alpha3 (with this method i can launch DosBox on hrev44563):

{{{
[Switching to team ./dosbox (56774) thread dosbox (56774)]
0x02d838d4 in std::locale::operator= () from /boot/apps/DOSBox/lib/libstdc++.so
(gdb) bt
#0  0x02d838d4 in std::locale::operator= () from /boot/apps/DOSBox/lib/libstdc++.so
#1  0x02d82752 in std::ios_base::_M_init () from /boot/apps/DOSBox/lib/libstdc++.so
#2  0x02d96b01 in std::basic_ios<char, std::char_traits<char> >::init ()
   from /boot/apps/DOSBox/lib/libstdc++.so
#3  0x0475dd88 in BPrivate::PlainTextCatalog::ReadFromFile ()
   from /boot/system/add-ons/locale/catalogs/gcc4/plaintext
#4  0x0475f6ea in BPrivate::PlainTextCatalog::PlainTextCatalog ()
   from /boot/system/add-ons/locale/catalogs/gcc4/plaintext
#5  0x0475fa6e in instantiate_catalog ()
   from /boot/system/add-ons/locale/catalogs/gcc4/plaintext
#6  0x02c4083a in BPrivate::MutableLocaleRoster::LoadCatalog ()
   from /boot/system/lib/gcc4/libbe.so
#7  0x02c3305c in BCatalog::SetTo () from /boot/system/lib/gcc4/libbe.so
#8  0x02c40546 in BPrivate::MutableLocaleRoster::LoadSystemCatalog ()
---Type <return> to continue, or q <return> to quit---
   from /boot/system/lib/gcc4/libbe.so
#9  0x02c39a14 in __initialize_locale_kit () from /boot/system/lib/gcc4/libbe.so
#10 0x02b66908 in initialize_after () from /boot/system/lib/gcc4/libbe.so
#11 0x02b5f9e2 in __haiku_init_after () from /boot/system/lib/gcc4/libbe.so
#12 0x02b4ca4a in _init () from /boot/system/lib/gcc4/libbe.so
#13 0x00100910 in init_dependencies () from /boot/system/runtime_loader
#14 0x00100d3c in load_program () from /boot/system/runtime_loader
#15 0x0010620a in runtime_loader () from /boot/system/runtime_loader
#16 0x7ffedfec in ?? ()
(gdb)
}}}

Change History (5)

comment:1 by umccullough, 8 years ago

Resolution: invalid
Status: newclosed

gcc4 versions of haiku are not guaranteed to be binary-compatible with previous versions.

Please try with a freshly rebuilt version of Dosbox.

comment:2 by Giova84, 8 years ago

Hi, i have tried to rebuild dosbox from Haikuporter, but the process ends with an error. How/where can i get a freshly rebuilt of DosBox?

in reply to:  2 comment:3 by SeanCollins, 8 years ago

Replying to Giova84:

Hi, i have tried to rebuild dosbox from Haikuporter, but the process ends with an error. How/where can i get a freshly rebuilt of DosBox?

3deyes is the provider of version 0.74 with the launcher. He typically updates software when alpha release, knowing his pattern of releases, I would expect a release sometime after the Alpha4 release. Hard to say when exactly.

comment:4 by Giova84, 8 years ago

I have successfully compiled the latest version of DOSBox on Haiku Alpha 4 branch: http://haikuware.com/directory/view-details/emulators/computer-systems/dosbox-074-svn-updated-for-alpha4

comment:5 by kallisti5, 8 years ago

Giova84 be sure to update the bep and submit it to ports.haiku-files.org :D

Note: See TracTickets for help on using tickets.