Opened 7 years ago

Closed 5 years ago

#9121 closed bug (fixed)

WebPositive downloads at 300 kb/s only

Reported by: haikurocks Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: download speed fixed. Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have noticed one thing it also happened to me in some different hardware configurations even with Be.Os and now in Haiku. When i start a download with browser it downloads always at 300 kb/s ( more or less ) and never goes faster, even when the connection is much faster. The interesting point is if i put 2-3-4 concurrent downloads they all go at same speed, 300 kb/s each. I have tried with different Virtualbox devices, with real hardware and in every computer works the same way.

Change History (11)

comment:1 by pulkomandy, 7 years ago

That could be the server limiting the speed. Does it work better on other systems ? Which browser did you use ? Did you try with the command-line tool wget ?

comment:2 by Coldfirex, 7 years ago

I assume you dont have this issue with the same downloads on other OSs? Which nic and nic drivers have you seen this on? Which build?

comment:3 by diver, 7 years ago

This might be a WebPositive issue as well. Try downloading the same file with wget.

comment:4 by haikurocks, 7 years ago

Well, fist excuse for the lack of tests before posting the error. The first i checked was wget and it works not at max possible speed but at least 50%-60% of my connection. The problem seems to happen only downloading with Webpositive ( haven´t tested with another browser sorry ). So i guess is about the browser. Webpositive downloads the same file than wget at only 300kb/s ( against 1.6MB/s for wget) Dunno if someone can reasign the bug so it belongs to the Webpositive team or something. Thanks for help.

comment:5 by diver, 7 years ago

Component: Network & InternetApplications/WebPositive
Owner: changed from nobody to leavengood
Summary: Downloads at 300 kb/s only.WebPositive downloads at 300 kb/s only

comment:6 by Kev, 7 years ago

I've also noticed this on WebPositive, recently on hrev45404 GCC4, hrev45362 GCC2h, and hrev45413 x86_64.

comment:7 by Kev, 7 years ago

Actually I just saw 318.11KiB/s on x86_64, but yeah.

Last edited 7 years ago by Kev (previous) (diff)

comment:8 by pulkomandy, 6 years ago

WebPositive now has a new network backend; is this still a problem ?

comment:9 by diver, 5 years ago

Probably fixed.

comment:10 by X512, 5 years ago

I can download files using WebPositive at 1.7 MiB/s. Bug seems to be fixed.

comment:11 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.