Opened 6 years ago

Closed 11 days ago

#9150 closed bug (fixed)

Old BeOS .psd translator destabilizes Haiku

Reported by: Premislaus Owned by: Nobody
Priority: normal Milestone: R1
Component: Add-Ons/Translators Version: R1/Development
Keywords: psd, translator Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

http://betips.net/1997/09/09/viewing-photoshop-files/ - Based on this information, I found in the web, psd translator for BeOS.

It works. But destabilizes Haiku. Clicking on it in DataTranslations causes crash. Tracker does not recognize the MIME type. But WonderBrush and Showimage reads these files. Unfortunately, after reading a few files, we need to kill Tracker and restart it. Otherwise, we can not do anything in Haiku. Start any program, browse the partition, etc..

Similarly behaves, translator of graphics files from ZX Spectrum.

Tested on Alpha 4.

Attachments (7)

BEPSD101.ZIP (25.9 KB) - added by Premislaus 6 years ago.
screenshot1.png (1.3 MB) - added by Premislaus 6 years ago.
to_many_files.png (138.7 KB) - added by Premislaus 6 years ago.
(find_button)blank.png (118.8 KB) - added by Premislaus 6 years ago.
PSDTranslator_crash_in_DataTranslations (7.9 KB) - added by Premislaus 6 years ago.
ZXTranslator.zip (39.5 KB) - added by Premislaus 6 years ago.
syslog (162.7 KB) - added by Premislaus 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Premislaus

Attachment: BEPSD101.ZIP added

Changed 6 years ago by Premislaus

Attachment: screenshot1.png added

Changed 6 years ago by Premislaus

Attachment: to_many_files.png added

Changed 6 years ago by Premislaus

Attachment: (find_button)blank.png added

Changed 6 years ago by Premislaus

Changed 6 years ago by Premislaus

Attachment: ZXTranslator.zip added

comment:1 Changed 6 years ago by diver

The crash is a dupe of #8352. "Too many files" error look suspicious, though.

Changed 6 years ago by Premislaus

Attachment: syslog added

comment:2 Changed 11 days ago by waddlesplash

Resolution: fixed
Status: newclosed

Doesn't crash anymore, and I don't get any stability issues.

Note: See TracTickets for help on using tickets.