Opened 7 years ago

Closed 5 weeks ago

#9176 closed bug (invalid)

Not booting with Asrock H61 M-DGS

Reported by: anandarpm Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/alpha4.1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hello,

The alpha4 was unabe to boot & shows the following message: PANIC: did not find any boot partitions ! Welcome to kernel Debugger Land ... Thread 16 "main2" running on CPU 0 Stack trace for thread 16 "main2" kernel stack: 0x02e36000 to 0x82e3d000 Frame coller <image> function + offset 0 082e39af8 (t32) 0012599a <kernel_x86> arch_debug_stack_trace() + 0x0012 . . 9 082e39fb4 (t48) 8007a0cc <kernel_x86> common_thread_entry_Fpr()+0x000 kdebug> ...............................................................................

Hardware Specification: Asrock H61 M-DGS, Have Win7 & arch installed on differnet parititions

CPU - Supports 3rd and 2nd Generation Intel® Core™ i7 / i5 / i3 in LGA1155 Package

  • Supports Intel® Turbo Boost 2.0 Technology
  • Supports Intel® K-Series unlocked CPU
  • Supports Hyper-Threading Technology

Chipset - Intel® H61

  • Supports Intel® Rapid Start Technology and Smart Connect Technology

*Intel® Rapid Start Technology and Smart Connect Technology are only supported under Windows® 7 OS or later versions. Memory - Dual Channel DDR3 memory technology

  • 2 x DDR3 DIMM slots
  • Supports DDR3 1600/1333/1066 non-ECC, un-buffered memory
  • Max. capacity of system memory: 16GB*
  • Supports Intel® Extreme Memory Profile (XMP) 1.3 / 1.2 with Intel® Ivy Bridge CPU

*Due to the operating system limitation, the actual memory size may be less than 4GB for the reservation for system usage under Windows® 32-bit OS. For Windows® 64-bit OS with 64-bit CPU, there is no such limitation.

DDR3 1600 with Intel® Ivy Bridge CPU, DDR3 1333 with Intel® Sandy Bridge CPU. BIOS - 32Mb AMI UEFI Legal BIOS with GUI support

  • Supports "Plug and Play"
  • ACPI 1.1 Compliance Wake Up Events
  • Supports jumperfree
  • SMBIOS 2.3.1 Support
  • IGPU, DRAM, PCH, CPU PLL, VTT, VCCSA Voltage Multi-adjustment Audio, Video and Networking

Graphics - Supports Intel® HD Graphics Built-in Visuals : Intel® Quick Sync Video 2.0, Intel® InTru™ 3D, Intel® Clear Video HD Technology, Intel® Insider™, Intel® HD Graphics 2500/4000 with Intel® Ivy Bridge CPU

  • Supports Intel® HD Graphics Built-in Visuals : Intel® Quick Sync Video, Intel® InTru™ 3D, Intel® Clear Video HD Technology, Intel® HD Graphics 2000/3000, Intel® Advanced Vector Extensions (AVX) with Intel® Sandy Bridge CPU
  • Pixel Shader 5.0, DirectX 11 with Intel® Ivy Bridge CPU. Pixel Shader 4.1, DirectX 10.1 with Intel® Sandy Bridge CPU.
  • Max. shared memory 1760MB with Intel® Ivy Bridge CPU. Max. shared memory 1759MB with Intel® Sandy Bridge CPU.
  • Dual VGA Output: Support DVI-D and D-Sub ports by independent display controllers
  • Supports DVI with max. resolution up to 1920x1200 @ 60Hz
  • Supports D-Sub with max. resolution up to 2048x1536 @ 75Hz
  • Supports HDCP function with DVI port
  • Supports Full HD 1080p Blu-ray (BD) / HD-DVD playback with DVI port

*Intel® HD Graphics Built-in Visuals and the VGA outputs can be supported only with processors which are GPU integrated.

Due to chipset limitation, the Blu-ray playback of Intel® HD Graphics is only supported under Windows® Vista™ and Windows® 7.

*Intel® InTru™ 3D is only supported under Windows® 7 and Windows® 7 x64. Audio - 5.1 CH HD Audio (Realtek ALC662 Audio Codec) LAN - PCIE x1 Gigabit LAN 10/100/1000 Mb/s

  • Realtek RTL8111C
  • Supports Wake-On-LAN
  • Supports PXE Expansion / Connectivity

Slots - 1 x PCI Express 3.0 x16 slot (blue @ x16 mode)

  • 1 x PCI Express 2.0 x1 slot

*PCIe Gen3 is supported on 3rd Generation of Intel® Core™ i5 and Core™ i7 CPUs. Connector - 4 x SATA2 3.0 Gb/s connectors, support NCQ, AHCI and Hot Plug functions

  • 1 x Print port header
  • 1 x COM port header
  • CPU/Chassis/Power FAN connector
  • 24 pin ATX power connector
  • 4 pin 12V power connector
  • Front panel audio connector
  • 2 x USB 2.0 headers (support 4 USB 2.0 ports)

Rear Panel I/O I/O Panel

  • 1 x PS/2 Mouse Port
  • 1 x PS/2 Keyboard Port
  • 1 x D-Sub Port
  • 1 x DVI-D Port
  • 6 x Ready-to-Use USB 2.0 Ports
  • 1 x RJ-45 LAN Port with LED (ACT/LINK LED and SPEED LED)
  • HD Audio Jack: Line in / Front Speaker / Microphone Other Features / Miscellaneous

Unique Feature - ASRock Extreme Tuning Utility (AXTU)

  • ASRock Instant Boot
  • ASRock Instant Flash
  • ASRock APP Charger
  • ASRock XFast USB
  • ASRock XFast LAN
  • ASRock XFast RAM
  • Hybrid Booster:
  • ASRock U-COP
  • Boot Failure Guard (B.F.G.)
  • Combo Cooler Option (C.C.O.)

Support CD - Drivers, Utilities, AntiVirus Software (Trial Version), CyberLink MediaEspresso 6.5 Trial, ASRock MAGIX Multimedia Suite - OEM Accessories - Quick Installation Guide, Support CD, I/O Shield

  • 2 x SATA Data Cables

Hardware Monitor - CPU Temperature Sensing

  • Chassis Temperature Sensing
  • CPU/Chassis/Power Fan Tachometer
  • CPU/Chassis Quiet Fan (Allow Chassis Fan Speed Auto-Adjust by CPU Temperature)
  • CPU/Chassis Fan Multi-Speed Control
  • Voltage Monitoring: +12V, +5V, +3.3V, CPU Vcore

Form Factor - Micro ATX Form Factor: 8.9-in x 6.8-in, 22.6 cm x 17.3 cm

  • Solid Capacitor for CPU power

OS - Microsoft® Windows® 7 / 7 64-bit / Vista™ / Vista™ 64-bit / XP / XP 64-bit compliant Certifications - FCC, CE, WHQL

  • ErP/EuP Ready (ErP/EuP ready power supply is required)

Change History (9)

comment:1 Changed 6 years ago by Randell

Maybe another incarnation of https://dev.haiku-os.org/ticket/9289 ?

comment:2 in reply to:  1 Changed 6 years ago by umccullough

Replying to Randell:

Maybe another incarnation of https://dev.haiku-os.org/ticket/9289 ?

Unlikely - "did not find any boot partitions" seems to be a pretty common issue while booting Haiku from CD. I can reproduce it on at least one of my machines, and by swapping from an IDE to SATA DVD drive (the HD was SATA I believe), I was able to finally boot. Others have reported issues detecting the CD depending on the combination of master/slave disks in an IDE setup - suggesting there are still some issues with the drive detection between SATA/IDE.

It seems to affect a decent number of people, but nobody has nailed down the specific cause yet - probably because none of the developers who have worked on these subsystems see the failure yet.

comment:3 Changed 6 years ago by umccullough

Component: - GeneralDrivers/Disk
Owner: changed from nobody to marcusoverhagen
Priority: criticalnormal

anandarpm,

Can you explain what medium you booted from? USB, CD - if CD, was it anyboot or iso?

comment:4 Changed 6 years ago by anandarpm

Hi umccullough, I used anyboot image of alpha 4 release burnt on CD. I have win7, Linux installed on two partitions with Grub2.

comment:5 Changed 6 years ago by umccullough

I'm tempted to mark this as a duplicate of one of the several other tickets reporting a similar issue - but since it's not entirely clear what exactly causes it yet, I'm not sure that's a good idea.

In any case, to be clear, the problem is that the kernel is unable to locate the Haiku BFS filesystem on the CD after it takes over from the BIOS. In my experience, when encountering this issue booting from a CD, I can often boot from a USB stick (using the very same anyboot image), successfully.

It has nothing to do with the physical disk and partition layout since those are not what the kernel is trying to locate at that point.

comment:6 Changed 5 years ago by korli

It seems there are two storage controllers on this motherboard.

It would be nice:

  • to have the "lspci" output on linux
  • to know in which mode your mass storage controllers are configured (AHCI or IDE)
  • to know how your cd drive is connected (USB/IDE/AHCI)

comment:7 Changed 5 years ago by luroh

anandarpm, any chance you could provide the requested information?

comment:8 Changed 11 months ago by cocobean

We can close this ticket and migrate it to UEFI/EFI testing enhancement ticket or wiki for better tracking.

User has a Asrock H61 M-DGS-based system.

Issue was mentioned as a installer/loader sync issue with BFS-partition on CD/DVD drives. Should consolidate this information for better isolation.

comment:9 Changed 5 weeks ago by waddlesplash

Resolution: invalid
Status: newclosed

No reply.

Note: See TracTickets for help on using tickets.