Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#929 closed bug (fixed)

When the console input displayed at the terminal screen doesn't provide a new line (as in r5).

Reported by: kaoutsis Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When the console input displayed at the screen doesn't provide a new line (as in hrev5). In other words, when the input datas of a program are displayed in the terminal screen, and the program had to display some info with cout, they are covered by cout.

Attachments (4)

mySmallInput.cpp (477 bytes) - added by kaoutsis 12 years ago.
my little silly input program
r5-console-result.png (81.5 KB) - added by kaoutsis 12 years ago.
the expected behavior in hrev5
haiku-before-pressing-enter.png (42.8 KB) - added by kaoutsis 12 years ago.
haiku-after-pressing-enter.png (32.4 KB) - added by kaoutsis 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by kaoutsis

Attachment: mySmallInput.cpp added

my little silly input program

Changed 12 years ago by kaoutsis

Attachment: r5-console-result.png added

the expected behavior in hrev5

Changed 12 years ago by kaoutsis

Changed 12 years ago by kaoutsis

comment:1 Changed 12 years ago by kaoutsis

and a small note: Haiku's terminal compiled for hrev5, doesn't have this problem.

comment:2 Changed 12 years ago by kaoutsis

Some new tests:

  • the same problem occurred instead of cin cout, a program uses scanf.
  • consoled doesn't seems to have this problem!

comment:3 Changed 12 years ago by kaoutsis

Testing with be's original Terminal running on haiku: the same problem. So i guess the problem is not in our terminal. The strange thing is that consoled doesn't have this problem!

comment:4 Changed 11 years ago by kaoutsis

Resolution: fixed
Status: newclosed

Possibly related to #1483. Tested again with hrev22359: In any case it's fixed!

comment:5 Changed 11 years ago by bonefish

Yes, this has been fixed quite a while ago actually. The tty driver wasn't echoing or processing the entered CRs correctly.

Note: See TracTickets for help on using tickets.