Opened 7 years ago

Closed 3 years ago

#9404 closed bug (fixed)

[Live CD] Can't connect to WPA2. Application could not be found

Reported by: Dilbert2 Owned by: Barrett
Priority: normal Milestone: R1/beta1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8545
Has a Patch: no Platform: All

Description

Version: hrev45205

Hi. I have a Asus G73Sw laptop. I want to run Haiku on it. I boot Haiku from CD, and it works fine. Wired network works fine.

But there is an issue with wireless networking. Immediately after loading the deskbar, I can see several available wireless networks. But they are all WPA2 encrypted. One of them is my own, and of course I have the password for it. I can also make my own wifi hotspot with my phone, without encryption.

Haiku, after loading, never refreshes the list of wifi networks. So I must turn on the phone hotspot before booting Haiku, or else Haiku does not find it. Haiku connects to the phone wifi without encryption just fine when booting.

But if I try to click on any of the encrypted networks, I get error message: Could not join wireless network: Application could not be found

So Haiku finds available wireless networks, but can`t connect to them if they have WPA2. Not sure if it would work with WEP. Also, I wish it would refresh the list without having to reboot.

Here is the lspci in Ubuntu on the same machine:

dilbert@G73Sw:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation GF106 [GeForce GTX 460M] (rev a1)
01:00.1 Audio device: nVidia Corporation GF106 High Definition Audio Controller (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 USB Controller: Fresco Logic FL1000G USB 3.0 Host Controller (rev 04)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
dilbert@G73Sw:~$ }}}

Change History (18)

comment:1 by diver, 7 years ago

Haiku, after loading, never refreshes the list of wifi networks.

Does issuing this refresh the list of wifi networks?

ifconfig /dev/net/atheroswifi/0 scan

Application could not be found

Check if you have /boot/common/bin/wpa_supplicant and that it has a signature. To do that open it in FileTypes Tracker add-on.

comment:2 by Dilbert2, 7 years ago

Interesting. Yesterday, when I wrote the bug report, I used hrev45205. Today, when I was going to answer your questions, I accidentally used an older disc. This is R1/alpha4 hrevr1 alpha4-44702.

So, I booted Haiku. Then I turned on my phone hotspot after Haiku was finished booting. The deskbar immediately listed "Galaxy" (my phone) as available, and automatically connected to it. It worked.

So, I deactivated wifi hotspot on my phone, and changed the network name from "Galaxy" to "Galaxyggg". Haiku did not notice that "Galaxy" was gone, and that "Galaxyggg" is available.

If I run: ifconfig /dev/net/atheroswifi/0 scan Then I get outdated information. It does not do a new scan. It lists "Galaxy", not "Galaxyggg".

Suddenly, several minutes later, the deskbar and the "scan" command will list "Galaxyggg", instead of the non-existing "Galaxy". Finally, it has updated the network list.

Just one problem: I now seem to be connected to "Galaxyggg", but I am not online. Ping works:

~> ping google.com
PING google.com (173.194.32.46): 56 data bytes
64 bytes from 173.194.32.46: icmp_seq=0 ttl=51 time=802.472 ms
64 bytes from 173.194.32.46: icmp_seq=1 ttl=51 time=69.276 ms
64 bytes from 173.194.32.46: icmp_seq=2 ttl=51 time=89.184 ms
64 bytes from 173.194.32.46: icmp_seq=3 ttl=51 time=78.821 ms
64 bytes from 173.194.32.46: icmp_seq=4 ttl=51 time=208.849 ms
64 bytes from 173.194.32.46: icmp_seq=5 ttl=51 time=108.794 ms
--- google.com ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 69.276/226.232/802.472/17137314.298 ms
~> 

But the browser fails to open any websites. How can this be? I know that "Galaxyggg" works, because my other laptop is currently connected to it, and it can surf the web.

Anyway, All this was with an older disc of Haiku. It has the same error message with wpa2-encrypted networks, where it says "Application could not be found".

I had to stick a ethernet cable into the laptop to post this. But the Ethernet cable also failed to work. Haiku would not get online at all!

So I had to use a memory stick to transfer this text that I was writing in Haiku, to another laptop.

comment:3 by Dilbert2, 7 years ago

I have now booted from the CD with hrev45205 again. I have tried to deactivate the phone´s wifi hotspot, changing the network name, and turning it back on several times. The Haiku Deskbar finds the new network name really fast. Great! It also connects. If I open Terminal and ping google.com, it works. But WebPositive fails to load websites. It seems I must restart WebPositive, when I connect to a new wifi network.

About your other question, about wpa_supplicant: Yes, it´s there. The signature is:

application/x-vnd.malinen-wpa_supplicant

comment:4 by Dilbert2, 7 years ago

Ok, I did a new boot from CD, using hrev45205.

In the deskbar I see several available networks. If I click on one that is WPA2 encrypted, I get a popup, saying:

Could not join wireless network:
Application could not be found

So, I go to /boot/common/bin and then I double-click on wpa_supplicant. Nothing happens, except the CD starts spinning again.

I then go to the deskbar again, and try to connect to a wpa2-encrypted network. This time I do not get that annoying error message! Instead, I get a box where I can type the encryption key for the network. So I type the encryption key. The deskbar gives a popup saying No link, then another popup saying Configuring. Then I get online and can surf the web! Great'''

So, I had to double click on wpa_supplicant, to make this work. Should it not start automatically?

Last edited 7 years ago by Dilbert2 (previous) (diff)

comment:5 by mmadia, 7 years ago

Given that Desktop mode is being entered on the CD, I'm curious if it's an issue with the mime script failing to identify wpa_supplicant?

comment:6 by Dilbert2, 7 years ago

Sorry, I do not understand what that means. What is Desktop mode and mime script?

I am not a programmer, but I´ll be happy to do some more trouble shooting.

Does this only happen to me, or does it happen to all who use hrev45205? Is it easy to fix?

comment:7 by luroh, 5 years ago

Milestone: R1R1/alpha5
Summary: Can`t connect to WPA2. Application could not be found[Live CD] Can't connect to WPA2. Application could not be found

The live CD functionality doesn't see much testing during the regular development cycle. For now, I'm bumping this one to the next release milestone, not due to its severity but due to it being a good test case for the release cycle live CD testing. Ideally, we should have relevant test cases and procedures wikified, cf. the ReleaseCookbook.

comment:8 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1

comment:9 by diver, 5 years ago

Since wpa_supplicant is now identified within its package is there anything to be done here?

comment:10 by pulkomandy, 5 years ago

Testing that it works when booted from a CD and confirm it's fixed. I didn't do it yet because I don't have a CD drive on my machines...

comment:11 by Barrett, 4 years ago

Owner: changed from axeld to Barrett
Status: newin-progress

I have some cd laying around, will check it in the next weeks.

comment:12 by kallisti5, 3 years ago

I think this one is resolved. I've booted from the Haiku live media and connected to wifi several times now. Can someone else confirm as well and close?

comment:13 by bruno, 3 years ago

Yes I can confirm it too... Live CD with wifi works... but sometimes its a bit tricky to get connected though...

comment:14 by bruno, 3 years ago

there are still problems with wpa-supplicant

comment:15 by kallisti5, 3 years ago

@bruno: going to need a lot more details than that :-)

a copy of /var/log/syslog ? a description of what kind of problems you're seeing ? authentication supported by the access point ?

comment:16 by bruno, 3 years ago

authentication supported by the access point ? where to check? In the router configuration?

comment:17 by pulkomandy, 3 years ago

Blocking: 8545 added

comment:18 by pulkomandy, 3 years ago

Resolution: fixed
Status: in-progressclosed

Confirmed working in https://dev.haiku-os.org/ticket/12482#comment:19 from CD. Let's track the remaning problems there.

Note: See TracTickets for help on using tickets.