Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9420 closed bug (fixed)

Radeon HD6870, regression of support for DVI-D port.

Reported by: Bouncer Owned by: kallisti5
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Radeon HD 6870 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I just built a gcc4 only compile of hrev45220. I just get black screens after the bootup completes.

On the exact same hardware, booting with alpha-4.1, it does recognize the monitor located on the DVI-D port.

Am including the two syslogs, for side by side comparison.

Attachments (4)

syslog.alpha4 (259.5 KB) - added by Bouncer 6 years ago.
This is the reference syslog from a Alpha-4.1 boot.
syslog.hrev45220 (235.8 KB) - added by Bouncer 6 years ago.
This is the syslog from the hrev45220 build.
syslog.DVI.hrev46552.txt (281.8 KB) - added by Bouncer 6 years ago.
Syslog for DVI-D connection (hrev46552)
syslog.DP.hrev46552.txt (561.3 KB) - added by Bouncer 6 years ago.
Syslog for DisplayPort connection (hrev46552)

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by Bouncer

Attachment: syslog.alpha4 added

This is the reference syslog from a Alpha-4.1 boot.

Changed 6 years ago by Bouncer

Attachment: syslog.hrev45220 added

This is the syslog from the hrev45220 build.

comment:1 Changed 6 years ago by kallisti5

definitely due to hrev45219

KERN: radeon_hd: Currently detected monitors=============== 4304 KERN: radeon_hd: Display #0 attached = true 4306 KERN: radeon_hd: + connector ID: 0 4308 KERN: radeon_hd: + connector type: DisplayPort 4310 KERN: radeon_hd: + encoder type: TMDS 4312 KERN: radeon_hd: + limits: Vert Min/Max: 56/75 4314 KERN: radeon_hd: + limits: Horz Min/Max: 30/81 4316 KERN: radeon_hd: Display #1 attached = true 4318 KERN: radeon_hd: + connector ID: 1 4320 KERN: radeon_hd: + connector type: DisplayPort 4322 KERN: radeon_hd: + encoder type: TMDS 4324 KERN: radeon_hd: + limits: Vert Min/Max: 56/75 4326 KERN: radeon_hd: + limits: Horz Min/Max: 30/81

The logs from 45220 show two displayport devices attached... is this true?

comment:2 Changed 6 years ago by Bouncer

Yes, Monitors 1 and 2 are both DisplayPort. The third monitor, is connected as DVI. This works fine for both W7 and Ubuntu. I have the DVI monitor physically set up as the middle of 3 monitors. (Just so I don't get a crick in my neck when running Haiku).

comment:3 Changed 6 years ago by kallisti5

Do monitors 1 and 2 work now?

There is a maximum set on the number of monitors that will function (2) at the moment until we can get the AppServer working properly with mulitple displays.

See #8612 for more info on this.

The reason we can't just "set the correct mode on all displays" is due to how DisplayPort devices function.

#8612 is the "real" fix I think. The reason this worked in your case previously was because radeon_hd didn't properly detect both DisplayPort monitors.

comment:4 Changed 6 years ago by Bouncer

Not sure what you mean. Here is a more precise description.

For Alpha4 build, Monitors 1 and 2 only work during the bootup sequence, displaying the icons. During this, monitor 3 (the DVI monitor) stays black. After the bootup 'rocket', monitors 1 and 2 go black, and monitor 3 would light up with the Haiku desktop. Now for build 45220. Everything appears exactly the same, Monitors 1 & 2 show the bootup icons, monitor 3 is black. After the rocket, monitors 1 & 2 go black, but now Monitor 3 stays black. I no longer get the desktop showing on the DVI display.

For now, I would be happy to have at least one of the monitors showing a display.

comment:5 Changed 6 years ago by kallisti5

This *might* be resolved by hrev45325

Please test once the latest nightly image (hrev45325 or later) comes out and let me know.

Changed 6 years ago by Bouncer

Attachment: syslog.DVI.hrev46552.txt added

Syslog for DVI-D connection (hrev46552)

Changed 6 years ago by Bouncer

Attachment: syslog.DP.hrev46552.txt added

Syslog for DisplayPort connection (hrev46552)

comment:6 Changed 6 years ago by Bouncer

Sorry for ignoring my own ticket for so long.

Just tested with a GCC4 build of hrev46522.

DVI-D connection works OK now. But DisplayPort gives me a black screen. Have attached syslogs for both.

This ticked, worded as it was specifically for DVI-D, can probably be closed.

comment:7 Changed 6 years ago by kallisti5

Resolution: fixed
Status: newclosed

hm, your logs show that Haiku actually doesn't find any active monitors when you only have displayport attached. It looks like the dp common code can't decode your displayport link speed. I'm going to push a change to print out what the raw value is on error... go ahead and open a new issue with that syslog (with only dp plugged in)

comment:8 Changed 6 years ago by kallisti5

(that syslog == the new one after trying hrev46553)

Note: See TracTickets for help on using tickets.