Opened 6 years ago

Closed 6 years ago

#9444 closed bug (fixed)

[setmime] misbehaves if not all args are specified

Reported by: ttcoder Owned by: siarzhuk
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: setmime Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Calling setmime -add to create a Tracker attribute column, without filling out all the arguments, results in "scratch" values (instead of default values) for these.

For instance, column width is set to "4029" pixels (!) if the -attrWidth argument is not used.

In BeOS, setmime (or maybe the registrar counterpart it talked to) gracefully set fall-back values.

Change History (4)

comment:1 Changed 6 years ago by ttcoder

Steps:

  • call e.g. setmime -add audio/x-mpeg -attribute tunetracker:spotid -attrName SpotID
  • open FileTypes, click on audio/x-mpeg

Expected:

  • all values initialized

Actual:

  • the right column shows "?£*#" and if you double-click the entry to see even more details, the column width is equal to 4029 pixels (!)

Things fare better if you specify most/all args as in e.g.

setmime -set audio/x-mpeg -attribute tunetracker:spotid -attrName SpotID -attrType CSTR -attrViewable 1 -attrEditable 1 -attrExtra 1 -attrWidth 60

but setmime should at least assign "0" rather than random values if not.

EDIT: forgot to mention this ticket might be the root cause of #9434

Last edited 6 years ago by ttcoder (previous) (diff)

comment:2 Changed 6 years ago by siarzhuk

Owner: changed from nobody to siarzhuk
Status: newassigned

comment:3 Changed 6 years ago by siarzhuk

Fixed in hrev45275. Thank you for the report!

comment:4 Changed 6 years ago by siarzhuk

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.