Opened 13 years ago

Closed 9 years ago

#946 closed bug (invalid)

Refreshing windows is a lot slow

Reported by: kaoutsis Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

a) clicking on a window for moving, causes a slow refresh to the related windows. (attachment movingWindow1.png & movingWindow2.png)

b) alt-F2 to change workspace and then alt-F1 to go back makes the windows to workspace 1 refreshing slow (attachment SlowRefresh-begin.png) after 1 second they look as the should (SlowRefresh-end.png)

Attachments (9)

movingWindow1.png (28.7 KB ) - added by kaoutsis 13 years ago.
movingWindow2.png (42.0 KB ) - added by kaoutsis 13 years ago.
SlowRefresh-begin.png (24.1 KB ) - added by kaoutsis 13 years ago.
slowRefresh-end.png (77.0 KB ) - added by kaoutsis 13 years ago.
syslogWithOldAti.txt (32.7 KB ) - added by kaoutsis 13 years ago.
ati-screenshot-800x600.png (72.7 KB ) - added by kaoutsis 13 years ago.
ati-screenshot-1024x768.png (89.0 KB ) - added by kaoutsis 13 years ago.
movingWindows.cpp (1.7 KB ) - added by kaoutsis 11 years ago.
Style changes
movingWindows-times.txt (241 bytes ) - added by kaoutsis 11 years ago.
updated to hrev26028

Download all attachments as: .zip

Change History (21)

by kaoutsis, 13 years ago

Attachment: movingWindow1.png added

by kaoutsis, 13 years ago

Attachment: movingWindow2.png added

by kaoutsis, 13 years ago

Attachment: SlowRefresh-begin.png added

by kaoutsis, 13 years ago

Attachment: slowRefresh-end.png added

comment:1 by kaoutsis, 13 years ago

Tested with haiku's vesa driver and with beos's old ati mach64 with no significant differences. the latest is some how better.

in reply to:  1 ; comment:2 by jackburton, 13 years ago

Replying to kaoutsis:

Please include your system description. I can't reproduce this problem, not even on qemu.

in reply to:  2 comment:3 by kaoutsis, 13 years ago

Replying to jackburton:

Replying to kaoutsis:

Please include your system description. I can't reproduce this problem, not even on qemu.

Sorry, i forgot. Some informations i gather for the machine: Processor Intel Pentim MMX 233 MHz System Buses ISA(16-bit), PCI(32-bit) System Bios Award 4.51 PG System Mainboard BIOSTAR Group (M5ATA) System Chipset Acer Labs Incorporated ALI M1531 ISA Bus ALI M1533 IDE Controller ALI M5229

RAM 104MB L2 External Cache 512 kB

ATA DISK drive ST34321A 8404830 sectors (4303 MB) w/128KiB Cache, CHS=523/255/63

CD/W drive TEAC CD-W540E

DVD-ROM drive SONY DDU1622

Isa Sound Card Creative ViBRA16C PnP Video Adapter ATI Rage II+ PCI (ati_m64)

comment:4 by kaoutsis, 13 years ago

And here is another test: i have attach the movingWindows.cpp a small test that invoking with the command: time movingWindows shows two moving windows, and show some response times i have tested in the machine with the above specifications both hrev5 and Haiku. The results: Time results in the same machine for R5 and Haiku, and with the same driver (old ati mach64) on pentium 233mmx ------- R5 ------------------------- real 0m7.542s user 0m0.240s sys 0m0.218s

------- haiku hrev19223 --------------- real 0m51.098s user 0m1.265s sys 0m1.524s

comment:5 by axeld, 13 years ago

Are you sure you're using the same driver? IIRC our Radeon driver does not support this card. Can you change the screen mode while Haiku is running?

in reply to:  5 comment:6 by kaoutsis, 13 years ago

perhaps i didn't made clear: i use on both hrev5 and haiku the same old original ati driver provided by beos hrev5. (i copied from the original hrev5).This driver runs well enough on Haiku (nothing to do with the new haiku driver for the newest ati). So with this old original beos driver i can change the screen mode on Haiku (1024x768)!!

by kaoutsis, 13 years ago

Attachment: syslogWithOldAti.txt added

by kaoutsis, 13 years ago

Attachment: ati-screenshot-800x600.png added

by kaoutsis, 13 years ago

Attachment: ati-screenshot-1024x768.png added

comment:7 by kaoutsis, 13 years ago

added the syslog with old hrev5 ati driver, and two screen shots for the testing pleasure :-)

comment:8 by diver, 13 years ago

Cc: diver added

Strange thing is that Deskbar don't use menu color settings, should we open another bug for this?

comment:9 by diver, 11 years ago

Does it still happen?

in reply to:  9 comment:10 by kaoutsis, 11 years ago

Replying to diver:

Does it still happen?

I ran again the movingWindows test with hrev25945: see attached movingWindows-times.txt. There is certainly an overall improvement.

by kaoutsis, 11 years ago

Attachment: movingWindows.cpp added

Style changes

by kaoutsis, 11 years ago

Attachment: movingWindows-times.txt added

updated to hrev26028

comment:11 by scottmc, 10 years ago

Can you run this again with a fresher version of Haiku?

comment:12 by luroh, 9 years ago

Resolution: invalid
Status: newclosed

Closing this one due to lack of feedback, please reopen if problem persists.

Note: See TracTickets for help on using tickets.