Opened 7 years ago

Closed 13 months ago

#9464 closed bug (fixed)

Hiding Connect Wireless Network window causes it to be lost

Reported by: ASoftwareHatingFurry Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/alpha4.1
Keywords: hiding hide minimise minimize minimising minimizing window connect network password Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When connecting to an encrypted wireless network, a window opens asking for a password.

If this window is double-clicked to hide it, it disappears without a trace - it is not listed in the Deskbar window list so it cannot be retrieved.

Clicking the wireless network again in the Deskbar network selector does not bring the window back. I can't seem to find any way to bring the window back again so the password can be entered, besides rebooting the system.

Apologies if this bug has already been filed, but searching for combinations of hiding+network seems to be returning stuff about hidden networks, nothing about hiding windows.

Change History (3)

comment:1 Changed 7 years ago by axeld

The window sits in the wpa_supplicant itself, so quitting that one should help. In any case, this is only an intermediary solution anyway -- the password should be retrieved (and stored) by a system service instead.

IOW this will get fixed once we switch over to the BKeyStore API.

comment:2 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:3 Changed 13 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

And we now use BKeyStore in wpa_supplicant.

Note: See TracTickets for help on using tickets.