Opened 6 years ago

Closed 5 years ago

#9509 closed enhancement (fixed)

Improve "top" utility screen redraw

Reported by: siarzhuk Owned by: nobody
Priority: low Milestone: R1
Component: Applications/Command Line Tools Version: R1/alpha4.1
Keywords: top Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As was already explained in haiku-development (see discussion about Terminal clear behaviour from 5 March 2013), Haiku version of top command-line utility is not perfect in information output. The problem is that every teams information snapshot is pushed into Terminal history instead of overwriting it inplace as other OS' top implementations do. The source of problem is Haiku Terminal implementation of the "clear all" command (\E[2J) - it just fill the screen with empty lines pushing old ones in the history. Possible solution can be refactoring Haiku top to use alternate screen buffer technique instead of normal buffer that is used in current top implementation. That is the way other top implementation go.

Change History (1)

comment:1 Changed 5 years ago by siarzhuk

Resolution: fixed
Status: newclosed

Fixed in hrev46472 during GCI 2013.

Note: See TracTickets for help on using tickets.