Opened 13 years ago

Closed 12 years ago

#955 closed bug (fixed)

Haiku wont respond if you boot it with mouse action

Reported by: diver Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: mmlr, axeld
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku wont respond if you boot it moving mouse around. When it boots, everything locks: time (seconds) in deskbar doesn't change, mouse doesn't work. If you stop to move your mouse, two seconds later haiku will alive.

Attachments (1)

serial.txt (478.1 KB) - added by diver 13 years ago.
syslog

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by axeld

Cc: marcusoverhagen added

This sounds like a problem of the PS/2 driver (probably a real time thread going nuts or some interrupt problem) - do you have any idea Marcus?

comment:2 Changed 13 years ago by marcusoverhagen

Cc: mmlr added
Summary: [PS/2] Haiku wont respond if you boot it with mouse actionHaiku wont respond if you boot it with mouse action

I think it's more likely a problem of USB, please attach a syslog or serial debug log.

comment:3 Changed 13 years ago by marcusoverhagen

Cc: axeld added
Owner: changed from axeld to marcusoverhagen

Diver please attach a syslog or serial debug log.

I couldn't reproduce the behaviour and would like to close this bug.

comment:4 Changed 13 years ago by marcusoverhagen

Resolution: invalid
Status: newclosed

comment:5 Changed 13 years ago by diver

Resolution: invalid
Status: closedreopened

Ok, i could now reproduce it in vmware with hrev19802. Reopening, syslog will follow

Changed 13 years ago by diver

Attachment: serial.txt added

syslog

comment:6 Changed 12 years ago by marcusoverhagen

Moving the mouse during boot does trigger sending (in this case) 13200 debug messages from interrupt context directly after the mouse is enabled, before the thread executing ps2_dev_command gets scheduled again and can set the enable flag.

The code responsible for that is:

	status = ps2_dev_command(dev, PS2_CMD_ENABLE, NULL, 0, NULL, 0);
	if (status < B_OK) {
		TRACE(("mouse_open(): cannot enable PS/2 mouse\n"));	
		goto err4;
	}
	atomic_or(&dev->flags, PS2_FLAG_ENABLED);

Please don't move the mouse during boot.

comment:7 in reply to:  6 Changed 12 years ago by jackburton

Replying to marcusoverhagen:

Moving the mouse during boot does trigger sending (in this case) 13200 debug messages from interrupt context directly after the mouse is enabled, before the thread executing ps2_dev_command gets scheduled again and can set the enable flag.

The code responsible for that is:

	status = ps2_dev_command(dev, PS2_CMD_ENABLE, NULL, 0, NULL, 0);
	if (status < B_OK) {
		TRACE(("mouse_open(): cannot enable PS/2 mouse\n"));	
		goto err4;
	}
	atomic_or(&dev->flags, PS2_FLAG_ENABLED);

Please don't move the mouse during boot.

Can't we disable or at least reduce the debug output of the ps2 driver ? Or it's still too early to do that ?

comment:8 Changed 12 years ago by marcusoverhagen

Cc: marcusoverhagen removed
Status: reopenednew

I'll disable the debug output of ps2

comment:9 Changed 12 years ago by marcusoverhagen

Resolution: fixed
Status: newclosed

fixed in hrev20357

Note: See TracTickets for help on using tickets.