Opened 6 years ago

Closed 6 years ago

#9559 closed bug (duplicate)

Out of bounds error in UserlandFSSserver.cpp causes GCC4 build to fail

Reported by: mounty Owned by: mmu_man
Priority: high Milestone: R1
Component: File Systems/NFS Version: R1/alpha4.1
Keywords: Cc:
Blocked By: #9522 Blocking:
Has a Patch: no Platform: All

Description

Line 173:

info->portInfos[0] = ...

fails to be compiled with GCC4 because the index is out of bounds.

I don't understand this code. FSConnectReply::portInfos is of type Address which doesn't define operator [] and isn't an array so I don't know why GCC thinks it should be indexable at all. Sorry but I don't have time to investigate further.

I've marked it as high priority because it's stopping building on GCC4.

Change History (1)

comment:1 Changed 6 years ago by umccullough

Blocked By: 9522 added
Resolution: duplicate
Status: newclosed

Duplicate of #9522

Note: See TracTickets for help on using tickets.