Opened 6 years ago

Closed 6 years ago

#9603 closed bug (duplicate)

Built-in card reader KDLs when card inserted

Reported by: Kev Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: Cc:
Blocked By: #9489 Blocking:
Has a Patch: no Platform: x86

Description

I have an eMachines T3104 (motherboard: VIA K8M800) with a card reader they describe as

"Media Reader: 8-in-1 digital media manager (Secure Digital (SD), Smart Media, Micro Drive, Memory Stick, Memory Stick Pro, Compact Flash, Mulitimedia Card, USB 2.0)"

When I insert an SD card that works fine on a Windows box, it turns on a green light (whether I've yet to get past the BIOS or not.)

In Haiku's DriveSetup on hrev45413 gcc4hybrid, the empty slots seem to show (see screenshot.) However, it doesn't let me mount or modify anything after inserting a card. Lately when I insert the card, I don't even get a chance to modify anything, because I get KDL'd with a division exception on "media checker".

I'm not sure if this has ever worked or what, and I only have Haiku and BeOS on this machine to work with.

Attachments (7)

drivesetup with sd card reader.png (84.5 KB) - added by Kev 6 years ago.
DriveSetup showing card reader empty slots
drivesetup no cards.png (36.7 KB) - added by Kev 6 years ago.
DriveSetup not showing the cards this time.
listusb.txt (8.4 KB) - added by Kev 6 years ago.
Output of listusb -v
syslog (447.9 KB) - added by Kev 6 years ago.
syslog.old (512.0 KB) - added by Kev 6 years ago.
just in case
P1070692.JPG (3.7 MB) - added by Kev 6 years ago.
qr code
P1070693.JPG (2.4 MB) - added by Kev 6 years ago.
KDL stack crawl

Change History (20)

Changed 6 years ago by Kev

DriveSetup showing card reader empty slots

comment:1 Changed 6 years ago by Kev

Okay, I just happened to have another time right after posting this where it did not KDL. So I had no programs running, I inserted the card, and nothing happened. So I tried launching DiskProbe. I pointed it at .../usb/0/0/raw (the SD card one) and clicked Probe Device. The window disappeared but DiskProbe stayed in Deskbar. Without killing it, I opened DriveSetup, and it added itself to Deskbar but also did not show a window. I pulled the card out, and both windows opened up, with DiskProbe showing a blank disk and DriveSetup showing the four card slots as in the screenshot (although other times, I have seen it without these, for some reason.) I then closed both programs, inserted the card, and it KDL'd again (Divide Error Exception in thread 37.)

Changed 6 years ago by Kev

Attachment: drivesetup no cards.png added

DriveSetup not showing the cards this time.

comment:2 Changed 6 years ago by Kev

I tried booting to BeOS R5.0.3, and interestingly, this is the only context in which I've seen the green light NOT come on and stay on when inserting the SD card. Normally it comes on immediately and only turns off when I take the card out. In BeOS it never came on. Also the card slots did not show in DriveSetup there. I left the card in and rebooted, and the BIOS paused in mid-sentence about the memory check, until I took the card out, and then it immediately resumed and booted normally. Then tried the card in another computer, works fine. Now, the same block that has the card readers also has a USB plug, and that's what my mouse uses, and it works fine, although I had a mouse with a sketchy cord that did not work when plugged into that USB port, despite working in BeOS in the same port, and on another computer.

I'm not sure what this all means.

comment:3 Changed 6 years ago by diver

Could you attach the syslog from such session?

comment:4 Changed 6 years ago by phoudoin

I suspect an USB card reader which don't behave totally like an compliant usb mass storage device.

Could you, please:

  • attach a capture of the KDL stack crawl (via the QR Code generator: "sc | qrappend" and then "qrflush", use your smartphone to read the QR content and post it there)
  • attach the output of the "listusb -v", so we could see how your card reader advertize itself to the system.

Regarding BeOS, as there is was USB mass storage support, your card reader device is not even talked to bye BeOS. Haiku does, but it seems it doesn't please that well the card reader ;-)

comment:5 in reply to:  4 Changed 6 years ago by Kev

Replying to phoudoin:

I suspect an USB card reader which don't behave totally like an compliant usb mass storage device.

Could you, please:

  • attach a capture of the KDL stack crawl (via the QR Code generator: "sc | qrappend" and then "qrflush", use your smartphone to read the QR content and post it there)
  • attach the output of the "listusb -v", so we could see how your card reader advertize itself to the system.

Regarding BeOS, as there is was USB mass storage support, your card reader device is not even talked to bye BeOS. Haiku does, but it seems it doesn't please that well the card reader ;-)

We have no smartphone to use here. Digital camera okay?

Will attach listusb -v, and syslog in a minute.

Changed 6 years ago by Kev

Attachment: listusb.txt added

Output of listusb -v

Changed 6 years ago by Kev

Attachment: syslog added

Changed 6 years ago by Kev

Attachment: syslog.old added

just in case

comment:6 Changed 6 years ago by Kev

Here's what happened. I rebooted, waited for desktop to come up and HDD to stop activity (which is an awesomely short time) and then opened DiskProbe. Saw no USB devices. Closed, put in card, opened, still nothing. Repeated "close, put in card, opened" a few times. Rebooted but stuck the card in. Had to pull it out a few times where it would freeze the boot process. Put it in during bootman. New thing: Haiku icons got all lit up, and then froze from there, full freeze, couldn't toggle the numlock. Took the card out, still frozen. Rebooted. After Haiku was fully loaded as in the first time, opened DiskProbe, saw the USB devices! Closed, put in card, KDL.

Rebooted to post this. Just checked DiskProbe and the USB devices are there again. It's like they need to be woken up somehow, and then they stay visible even between reboots.

Changed 6 years ago by Kev

Attachment: P1070692.JPG added

qr code

comment:7 Changed 6 years ago by Kev

Sorry, I didn't realize there are online tools for this. Hang on

comment:8 Changed 6 years ago by Kev

Well, they didn't work. Hopefully someone else has better luck.

comment:9 Changed 6 years ago by kallisti5

Contents of P1070692.JPG:

stack trace for thread 37 "media checker"
    kernel stack: 0x816e3000 to 0x816e7000
frame               caller     <image>:function + offset
0 816e69b4 (+  32) 800859a5   <kernel_x86> invoke_command_trampoline(void*: [34m0x816e6a28 [0m) + 0x15
1 816e69d4 (+  12) 801030e2   <kernel_x86> arch_debug_call_with_fault_handler + 0x1b
2 816e69e0 (+  48) 800836e9   <kernel_x86> debug_call_with_fault_handler + 0x50
3 816e6a10 (+  64) 80085ba9   <kernel_x86> invoke_debugger_command + 0xbe
4 816e6a50 (+  64) 80085ce2   <kernel_x86> invoke_pipe_segment(debugger_command_pipe*: NULL, int32: [34m2 [0m, char*: [34m0xcce38030 [0m) + 0x6f
5 816e6a90 (+  48) 80085dc6   <kernel_x86> invoke_debugger_command_pipe + 0xa6
6 816e6ac0 (+  64) 8008a17d   <kernel_x86> ExpressionParser< [32m0x816e6b8

comment:10 Changed 6 years ago by kallisti5

looks like the backtrace contained to much data and the qr generated cut off important bits.

Maybe we just need a camera image of the backtrace? :)

comment:11 Changed 6 years ago by Kev

I'll see what I can do. BTW how did you decode it? Just use a smartphone? I had tried http://blog.qr4.nl/Online-QR-Code_Decoder.aspx also with a cropped image.

So I just run sc this time?

comment:12 in reply to:  11 Changed 6 years ago by kallisti5

Replying to Kev:

I'll see what I can do. BTW how did you decode it? Just use a smartphone? I had tried http://blog.qr4.nl/Online-QR-Code_Decoder.aspx also with a cropped image.

My Galaxy Nexus :)

So I just run sc this time?

Yeah, just run sc and get the best picture of the screen as you can. The QR code stuff is awesome... but there is a limit to how much text it can hold (and these stack traces run a little long)

Changed 6 years ago by Kev

Attachment: P1070693.JPG added

KDL stack crawl

comment:13 Changed 6 years ago by kallisti5

Blocked By: 9489 added
Resolution: duplicate
Status: newclosed

ah. This is a 100% duplicate of my issue :D

#9489 shows an identical error

Note: See TracTickets for help on using tickets.