Opened 6 years ago

Closed 5 years ago

#9605 closed bug (fixed)

Web+ sometimes fails to download FTP URLs

Reported by: Kev Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description (last modified by pulkomandy)

E.g. ftp://ftp.mrunix.net/pub/webalizer/README is hard to read because linebreaks are treated as regular whitespace in HTML, but it's not an HTML page. Not sure how firefox does it but wrapping in a <pre> tag in such cases would be an easy way to increase usability.

hrev45413 gcc4h.

Change History (4)

comment:1 Changed 6 years ago by Kev

Still there on hrev46198.

comment:2 Changed 5 years ago by pulkomandy

The link in this ticket is FTP, which we currently don't open in Web+ at all. Do you have an example of an HTTP page where this happens?

comment:3 Changed 5 years ago by Kev

Summary: Web+ displays text documents as HTMLWeb+ sometimes fails to download FTP URLs

Oh, interesting that it had sort of worked before. On hrev46756, Web+ launches a Terminal window and tries to download the file, but fails:

Connected to zeus.mrunix.net.
220 WU-ftpd V2.1 FTP Server at MrUnix - Welcome!
331 Please specify the password.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
200 Switching to Binary mode.
250 Directory successfully changed.
250-
250-Welcome to the official home of The Webalizer.
250-A Fast, Free web server log analysis program.
250-
250-As always, if you encounter problems or have suggestions, drop
250-me a note at brad at mrunix dot net.
250-
250-This program is distributed in the hope that it will be useful,
250-but WITHOUT ANY WARRANTY; without even the implied warranty of
250-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
250-files "COPYING" (GNU General Public License) and "Copyright"
250-for more details.
250 Directory successfully changed.
local: README remote: README
227 Entering Passive Mode (184,173,240,168,252,65).
150 Opening BINARY mode data connection for README (102611 bytes).
ftp: local: README: Invalid Argument
226 Transfer complete.
225 No transfer to ABOR.
221 Goodbye.
Press any key

As you asked, I found an HTTP example, http://www.about.com/robots.txt, which works fine vis. the OP. Another example not ending in .txt was http://ai.eecs.umich.edu/people/dreeves/mash/README, which also worked fine. So you're right, it's now an FTP-specific thing but the problem is a bit different than the original.

comment:4 Changed 5 years ago by pulkomandy

Description: modified (diff)
Resolution: fixed
Status: newclosed

The current FTP issue is tracked in #9905. When that is done we will have a nice directory listing, as was tested with file: and gopher: protocols already.

Note: See TracTickets for help on using tickets.