Opened 13 years ago

Closed 11 years ago

#961 closed bug (fixed)

app_server allows resizing of window frame when it's not supposed to

Reported by: genki0 Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hi,

It's possible to resize a window when it's set to avoid focus or something similiar.

Start media player, show about box, now start resizing window. Notice how the window contents are not updated..

Also, it seems that the update events are leaked or possibly queued inside the app_server, because every time you resize the window, app_server memory usage will grow slightly. (use processcontroller to see)

/jens

Attachments (1)

bm.jpg (51.5 KB ) - added by genki0 13 years ago.

Download all attachments as: .zip

Change History (3)

by genki0, 13 years ago

Attachment: bm.jpg added

comment:1 by stippi, 12 years ago

Owner: changed from axeld to stippi
Status: newassigned

comment:2 by stippi, 11 years ago

Resolution: fixed
Status: assignedclosed

I cannot reproduce this at all, at least, I have no idea what you mean. When I show the MediaPlayer about box, the MediaPlayer window itself does not get focus (blocked by the modal alert). I can still resize it, which is the correct behavior. While resizing, the contents update as they should. I also don't notice any memory leak in app_server, although I am pretty sure there may be some left here and there. If a specific memory leak is observed, please open a separate bug for it.

Note: See TracTickets for help on using tickets.